struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Hill" <andrew.david.h...@gridnode.com>
Subject Is it possible to use struts 1.1 with WebSphere 4?
Date Wed, 11 Jun 2003 11:25:57 GMT
We need to see if its possible to make our big complex application work on
WebSphere 4. We had it working on 5.
The ui is done in struts and it was suggested that struts1.1 couldnt be used
with WepSphere 4 as WS4 uses the 2.2 servlet API. I figured this shouldnt be
a problem as struts supports 2.2 and doesnt need 2.3

Nevertheless I havent even been able to get a simple test application to run
on WAS4. (Something of a struts equivalent to hello world". - One action
that does a println to the response to prove you reached it)

This test app deploys and runs just fine in tomcat 3.3.1a (a servlet api 2.2
container) and of course in 4.0.6, but on websphere the ActionServlet dies
in the init method with:

SRVE0100E: Did not realize  init() exception thrown by servlet action:
javax.servlet.UnavailableException: Parsing error processing resource path
	at
org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:9
52)
	at org.apache.struts.action.ActionServlet.init(ActionServlet.java:468)
	at javax.servlet.GenericServlet.init(GenericServlet.java:258)
	at
com.ibm.servlet.engine.webapp.StrictServletInstance.doInit(ServletManager.ja
va:802)
	at
com.ibm.servlet.engine.webapp.StrictLifecycleServlet._init(StrictLifecycleSe
rvlet.java:137)
	at
com.ibm.servlet.engine.webapp.PreInitializedServletState.init(StrictLifecycl
eServlet.java:243)
	at
com.ibm.servlet.engine.webapp.StrictLifecycleServlet.init(StrictLifecycleSer
vlet.java:103)
	at
com.ibm.servlet.engine.webapp.ServletInstance.init(ServletManager.java:388)
	at javax.servlet.GenericServlet.init(GenericServlet.java:258)
	at
com.ibm.servlet.engine.webapp.ServletManager.addServlet(ServletManager.java:
84)
	at
com.ibm.servlet.engine.webapp.WebAppServletManager.loadServlet(WebAppServlet
Manager.java:226)
	at
com.ibm.servlet.engine.webapp.WebAppServletManager.loadAutoLoadServlets(WebA
ppServletManager.java:357)
	at
com.ibm.servlet.engine.webapp.WebApp.loadServletManager(WebApp.java:1001)
	at com.ibm.servlet.engine.webapp.WebApp.init(WebApp.java:133)
	at com.ibm.servlet.engine.srt.WebGroup.loadWebApp(WebGroup.java:234)
	at com.ibm.servlet.engine.srt.WebGroup.init(WebGroup.java:139)
	at
com.ibm.servlet.engine.ServletEngine.addWebApplication(ServletEngine.java:63
3)
	at com.ibm.ws.runtime.WebContainer.install(WebContainer.java:36)
	at com.ibm.ws.runtime.Server.startModule(Server.java:615)
	at com.ibm.ejs.sm.active.ActiveModule.startModule(ActiveModule.java:509)
	at com.ibm.ejs.sm.active.ActiveModule.startAction(ActiveModule.java:355)
	at com.ibm.ejs.sm.active.ActiveObject.startObject(ActiveObject.java:709)
	at com.ibm.ejs.sm.active.ActiveObject.start(ActiveObject.java:131)
	at java.lang.reflect.Method.invoke(Native Method)
	at
com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(AdminAgentImpl.ja
va:93)
	at
com.ibm.ejs.sm.active.ActiveObject.invokeContainedObject(ActiveObject.java:5
12)
	at
com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(AdminAgentImpl.ja
va:110)
	at
com.ibm.ejs.sm.agent.AdminAgentImpl.invokeActiveObject(AdminAgentImpl.java:6
2)
	at
com.ibm.ejs.sm.agent._AdminAgentImpl_Tie._invoke(_AdminAgentImpl_Tie.java:80
)
	at
com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(ExtendedServerDelegate.ja
va:506)
	at com.ibm.CORBA.iiop.ORB.process(ORB.java:2294)
	at com.ibm.CORBA.iiop.OrbWorker.run(OrbWorker.java:185)
	at com.ibm.ejs.oa.pool.ThreadPool$PooledWorker.run(ThreadPool.java:95)
	at com.ibm.ws.util.CachedThread.run(ThreadPool.java:122)

Is this just something Im doing wrong (ideas on what would be appreciated!),
or is it really true that you cant use struts 1.1 with websphere 4?




<useless-information>
Its a simple app I banged together with one action that writes a string
directly to the response.
Its got a whole bunch of libs in WEB-INF/lib as Im not sure what struts
needs and doesnt:
ie:
commons-beanutils.jar
commons-collections.jar
commons-dbcp.jar
commons-digester.jar
commons-fileuplaod.jar
commons-lang.jar
commons-logging.jar
commons-pool.jar
commons-resources.jar
commons-validator.jar
jakarta-oro.jar
jdbc2_0-stdext.jar
log4j-1.2.7.jar
struts.jar

My logging properties are set up to use log4j, though Im not calling the log
in my action.
Various config files are in my WEB-INF
struts-config.xml
tiles-def.xml
validation.xml
web.xml

struts-config has been set up as simple as possible - just maps one path to
one action. The other files are untouched and would be same as whats in the
struts blank war.
</useless-information>


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message