struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erez Efrati <er...@netmedia.net.il>
Subject RE: module / tiles problems
Date Sun, 13 Jul 2003 13:14:58 GMT
Just by looking and I am new to tiles...
That the  

<set-property property="moduleAware" value="false" />

The VALUE should be set to TRUE not false.

Hope it helps,
Erez

-----Original Message-----
From: Nathan Coast [mailto:nathan@codeczar.com] 
Sent: Sunday, July 13, 2003 2:12 PM
To: struts-user
Subject: module / tiles problems

Hi,

I tried setting up a web application with configuration files.

<init-param>
<param-name>config</param-name> 
<param-value>/WEB-INF/struts-config.xml,/WEB-INF/struts-config-logweb.xm
l</param-value>
</init-param>

both referred to their own tiles-defs files with tiles plugins

   <plug-in className="org.apache.struts.tiles.TilesPlugin" >
     <set-property property="definitions-config" 
value="/WEB-INF/tiles-defs.xml" />
     <set-property property="definitions-parser-validate" value="true"
/>
     <set-property property="moduleAware" value="false" />
   </plug-in>

and

   <plug-in className="org.apache.struts.tiles.TilesPlugin" >
     <set-property property="definitions-config" 
value="/WEB-INF/tiles-defs-logweb.xml" />
     <set-property property="definitions-parser-validate" value="true"
/>
     <set-property property="moduleAware" value="false" />
   </plug-in>

the tiles-defs were only loaded for the file listed in the first config 
file (struts-config.xml)

Am I doing something wrong?

thanks
Nathan


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message