struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinit Sharma <mail2vi...@yahoo.com>
Subject Re: Struts 1.1 migration
Date Fri, 25 Jul 2003 06:52:51 GMT
Hello
I'm using the DTD version as provided by Struts site for Struts 1.1. It is as follows:
<!DOCTYPE struts-config PUBLIC
       "-//Apache Software Foundation//DTD Struts Configuration 1.1//EN"
       "http://jakarta.apache.org/struts/dtds/struts-config_1_1.dtd">
Is there anything wrong with that??
Vinit

Siva <sivakumarv@india.adventnet.com> wrote:
Dea rVinit,

Please use the propert dtd version corresponds to 1.1 (you can specify the dtd available in
SUN site.) I feel the peoblem is because of improper dtd reference..

Siva

Vinit Sharma wrote:

> Hello
> I'm migrating from Struts 1.0 to Struts 1.1. My old struts-config.xml file does not work
properly here. I've defined a form bean as follows:
>
> > type="com.temp.user" >
> 
> 
>
> I got following error while I start my Weblogic server:
>
> javax.servlet.UnavailableException: Parsing error processing resource path
> at org.apache.struts.action.ActionServlet.handleConfigException(ActionServlet.java:1035)
> at org.apache.struts.action.ActionServlet.parseModuleConfigFile(ActionServlet.java:1014)
> at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:955)
> at org.apache.struts.action.ActionServlet.init(ActionServlet.java:470)
> at javax.servlet.GenericServlet.init(GenericServlet.java:258)
> at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:713)
> at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:656)
> at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:601)
> at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2272)
> at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2216)
> at weblogic.servlet.internal.HttpServer.preloadServlets(HttpServer.java:495)
> at weblogic.servlet.internal.WebService.preloadServlets(WebService.java:450)
> at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:49)
> at java.lang.Thread.run(Thread.java:479)
>
>
> Line no. 1035 in ActionServlet.java is:
> throw new UnavailableException(internal.getMessage("configParse", paths));
> and line no. 1014 in ActionServlet.java is inside a catch block of SAXException. I thought
it is due to XML parsing error. May be because my weblogic server is using older version of
JAXP, but Weblogic 6.1 use the version 1.1
> If I remove the line for set-property, it works fine.
> Can any body help me in that??
> Thanks and regards.
> Vinit
>
> ---------------------------------
> Do you Yahoo!?
> Yahoo! SiteBuilder - Free, easy-to-use web site design software


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org



---------------------------------
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message