struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Raeburn" <sraeb...@apache.org>
Subject RE: Subject RE: Multiple modules - Please help
Date Tue, 29 Jul 2003 16:49:01 GMT
Ajay,
I've closed this bug. It seems to be a configuration problem...

I'm assuming that your add.jsp and edit.jsp files are in the /admin
directory.

The problem is with your configuration. ForwardAction requires a CONTEXT
relative path which, in this case would be:

 <action path="/showEdit"
         type="org.apache.struts.actions.ForwardAction"
         parameter="/admin/edit.jsp">
 </action>

(Note also, you had your parameter in a separate tag, but it should be an
attribute of the action tag. Not sure if that's what you actually had in
your
source or it's just a typo in the bug report, but it wouldn't help!)

The reason it worked when you used your own custom action is that by default
ActionFoward paths are MODULE relative, so your configuration entry
"/edit.jsp"
would be translated by the RequestProcessor to a context relative path of
"/admin/edit.jsp"

... if you still have problems after this, please post back to the user
list.

Steve

> -----Original Message-----
> From: Steve Raeburn [mailto:sraeburn@apache.org]
> Sent: July 28, 2003 9:13 PM
> To: Struts Users Mailing List
> Subject: RE: Subject RE: Multiple modules - Please help
>
>
> Glad you got it working. I'll take a look at your bug report and see if I
> can sort out what's happening with ForwardAction.
>
> Steve
>
>
> > -----Original Message-----
> > From: Ajay Patil [mailto:apatil@vertex.co.in]
> > Sent: July 28, 2003 8:28 PM
> > To: struts-user@jakarta.apache.org
> > Subject: Subject RE: Multiple modules - Please help
> >
> >
> > Dear Steve,
> >
> > > Can you access the edit or remove actions by entering the URL in your
> > > address bar?
> > > e.g. http://localhost:8080/myapp/admin/edit.do?parameter=XXX
> >
> > Your tip helped me to debug the problem.
> >
> > Apparently, I got the 404 error from the browser.
> > In the config file, edit.do was declared to be of type "ForwardAction".
> > I created a new action class and used it instead of ForwardAction.
> >
> > and voila, it worked !
> >
> > So, it might be a bug in ForwardAction.
> >
> > I have posted a bug at
> > http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21949
> >
> > Thanks,
> > Ajay
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: struts-user-help@jakarta.apache.org
> >
> >
> >
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: struts-user-help@jakarta.apache.org
>
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message