struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rajendra.x.ya...@verizon.com
Subject Re: modules.
Date Wed, 16 Jul 2003 11:46:44 GMT

I think the <servlet-mapping> tag.

Thanks
-raj



                                                                                         
                                             
                      "Eugen Bushuev"                                                    
                                             
                      <bu@lucky.net>           To:       struts-user@jakarta.apache.org
                                               
                                               cc:                                       
                                             
                      16/07/2003 04:56         Subject:  modules.                        
                                             
                      PM                                                                 
                                             
                      Please respond to                                                  
                                             
                      "Struts Users                                                      
                                             
                      Mailing List"                                                      
                                             
                                                                                         
                                             
                                                                                         
                                             




Hi.
My modules do not wont to work.
I have:
web.xml:
...
  <servlet>
    <servlet-name>action</servlet-name>
    <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
...
    <init-param>
       <param-name>config/test</param-name>
       <param-value>/WEB-INF/struts-test-config.xml</param-value>
    </init-param>
    <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/struts-config.xml</param-value>
    </init-param>
.....
struts-config.xml - empty,

struts-test-config:
    <action path="/testaction"
            type="test.web.TestAction">
    </action>
  </action-mappings>

than, in /test/test.jsp
    <html:form action="/testaction" focus="name">

gives

Cannot retrieve mapping for action /testaction


what i'm missing here?
senx.

--
С уважением, Е.Бушуев.


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org




Mime
View raw message