struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kris Schneider <k...@dotech.com>
Subject RE: Re[2]: EL Expression in html:hidden tag
Date Mon, 03 Nov 2003 18:20:31 GMT
I'm jumping in late on this thread, but why bother using Struts-EL at all under
JSP 2.0? The original (RT) tags should be magically EL-aware as long as the app
uses a Servlet 2.4 format web.xml, right?

<?xml version="1.0" encoding="ISO-8859-1"?>
<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
         version=”2.4”>
  ...
</web-app>

Quoting "Karr, David" <David.Karr@wamu.net>:

> > -----Original Message-----
> > From: Arne Brutschy [mailto:mai01cvr@studserv.uni-leipzig.de] 
> > 
> > Thursday, October 30, 2003, 3:53:39 PM, you wrote:
> > RB> Is ${pageContext.request.servletPath} returning anything?
> > Yes, it is returning the right path.
> > 
> > RB>  Try something like
> > RB> <html:hidden property="requestedPage"><c:out
> > RB> value="${pageContext.request.servletPath}"/></html:hidden>
> > I already tried this, it does not work. Basically, it should be the
> > same as
> > 
> >   <html:hidden property="requestedPage">
> >     ${pageContext.request.servletPath}
> >   </html:hidden>
> > or
> >   <html:hidden property="requestedPage" 
> > value="${pageContext.request.servletPath}"/>
> > 
> > which are both not working. Is this some stutsbug? Why is the
> > html:hidden tag marked in the tld file with a rtexpressions=false?
> 
> OH.  Sigh.  I had originally set all the attributes on the EL tags to
> have that set to "false", because in JSP 1.2 that refers to whether it
> will use scriptlet expressions or not, and I wanted to discourage the
> use of those.  I had recently decided to change those back to "true" out
> of a sudden attack of pragmatism, but now I see that this (the "false"
> setting) is causing a more serious problem.  In JSP 2.0, the meaning of
> this flag is slightly different (I'm assuming) in that it appears a
> setting of "false" means it won't evaluate EL expressions.
> 
> I'll try to get to fixing these tonight and getting it into the nightly
> build, at least.

-- 
Kris Schneider <mailto:kris@dotech.com>
D.O.Tech       <http://www.dotech.com/>

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message