struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hubert Rabago <jakartau...@yahoo.com>
Subject Re: ForwardAction not picking up Tiles defs?
Date Mon, 03 Nov 2003 22:12:48 GMT
In the debug output of Tiles/simplelog.

'.baseLayout' - processed as uri
-or-
'.baseLayout' - processed as definition

should appear there just before the request fails.
Before these lines, there should be a "processForwardConfig(.baseLayout,..."
as well.

--- "Ruth, Brice" <bruth@fiskars.com> wrote:
> Where should I be looking for this message?
> 
> Hubert Rabago wrote:
> 
> >I haven't tried that before, either.  AFAIK, having the plug-in takes care of
> >installing the TilesRequestProcessor -- you don't have to specify it.  But
> since
> >a subclass works, having that should work, too.
> >
> >When you run the code, does it show the ff message:
> >
> >'.baseLayout' - processed as uri
> >
> >?
> >
> >--- "Ruth, Brice" <bruth@fiskars.com> wrote:
> >  
> >
> >>Only one struts-config.xml, and only the default RequestProcessor, far 
> >>as I know ... here's the "controller" config parameter in struts-config.xml
> >>
> >>    <controller
> >>        processorClass="org.apache.struts.tiles.TilesRequestProcessor"
> >>        nocache="true" locale="false"/>
> >>
> >>
> >>Hubert Rabago wrote:
> >>
> >>    
> >>
> >>>I dunno.  Try to find some other possible causes.  Do you only have one
> >>>struts-config.xml?  Maybe you have multiple and the different plug-ins are
> >>>causing problems.  Are you using a custom RequestProcessor?  If you are,
it
> >>>      
> >>>
> >>must
> >>    
> >>
> >>>extend TilesRequestProcessor or else Tiles can't intercept your forwards.
 
> >>>
> >>>--- "Ruth, Brice" <bruth@fiskars.com> wrote:
> >>> 
> >>>
> >>>      
> >>>
> >>>>No difference ... just changed it to /tilestest.
> >>>>
> >>>>Hubert Rabago wrote:
> >>>>
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>I've had success with tile names starting with ".", and with
> ForwardAction. 
> >>>>>          
> >>>>>
> >>I
> >>    
> >>
> >>>>>haven't combined both yet, but can't imagine why a combination would
fail.
> >>>>>What I haven't tried is a path like "/US/tilestest".  It's always
been
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>"/myPath"
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>for me.  
> >>>>>Don't know if that helps.
> >>>>>
> >>>>>--- Mikael Eriksson - Swedish Connection <mikael@connection.se>
wrote:
> >>>>>
> >>>>>
> >>>>>     
> >>>>>
> >>>>>          
> >>>>>
> >>>>>>One thing to try might be to use tile names that does not start
with a
> dot.
> >>>>>>I have done things that look pretty similar but the tilenames
was things
> >>>>>>            
> >>>>>>
> >>like
> >>    
> >>
> >>>>>>output.page1.  The parsing might get confused or by the starting
'.'
> >>>>>>My actions look like:
> >>>>>>
> >>>>>>   <action path="/tiles_page1_in"
> >>>>>>          type="org.apache.struts.actions.ForwardAction"
> >>>>>>          parameter="output.page1" />
> >>>>>>
> >>>>>>
> >>>>>>Regards
> >>>>>>
> >>>>>>
> >>>>>>At 15:26 2003-11-03 -0600, you wrote:
> >>>>>>  
> >>>>>>
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>>>>I'm ripping my hair out here, guys ... what's going on with
my config?!
> I 
> >>>>>>>can't see anything wrong in the debug output, yet Struts
still is
> balking 
> >>>>>>>at actions that use the ForwardAction class and don't have
a parameter 
> >>>>>>>that starts with a '/' ...
> >>>>>>>
> >>>>>>>Please, please help!! (currently in begging mode, bribing
is next :))
> >>>>>>>
> >>>>>>>Ruth, Brice wrote:
> >>>>>>>
> >>>>>>>    
> >>>>>>>
> >>>>>>>         
> >>>>>>>
> >>>>>>>              
> >>>>>>>
> >>>>>>>>OK, I have simplelog set to debug and I don't see any
errors - it seems
> 
> >>>>>>>>to parse my tiles-def.xml just fine, from what I can
see.
> >>>>>>>>
> >>>>>>>>?!?
> >>>>>>>>
> >>>>>>>>Hubert Rabago wrote:
> >>>>>>>>
> >>>>>>>>      
> >>>>>>>>
> >>>>>>>>           
> >>>>>>>>
> >>>>>>>>                
> >>>>>>>>
> >>>>>>>>>I got this yesterday.  It means Tiles didn't intercept
your forward
> >>>>>>>>>             
> >>>>>>>>>
> >>>>>>>>>                  
> >>>>>>>>>
> >>>>request
> >>>>   
> >>>>
> >>>>        
> >>>>
> >>>>>>>>>because 1) Tiles wasn't called or 2) Tiles didn't
recognize your tile.
> >>>>>>>>>If you turn debug on for Tiles (org.apache.struts.tiles),
it'll dump
> the
> >>>>>>>>>                  
> >>>>>>>>>
> >>>>>>>>>tiles
> >>>>>>>>>it'll recognize when you app starts up.  Make sure
yours is listed.
> >>>>>>>>>
> >>>>>>>>>I'm using a tile with a ForwardAction now, so I know
it works.  Hope
> you
> >>>>>>>>>                  
> >>>>>>>>>
> >>>>>>>>>find it.
> >>>>>>>>>
> >>>>>>>>>--- "Ruth, Brice" <bruth@fiskars.com> wrote:
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>        
> >>>>>>>>>
> >>>>>>>>>             
> >>>>>>>>>
> >>>>>>>>>                  
> >>>>>>>>>
> >>>>>>>>>>I'm following the instructions provided here:

> >>>>>>>>>>http://jakarta.apache.org/struts/userGuide/building_view.html
> (section 
> >>>>>>>>>>3.4.3) for incorporating tiles definitions in
struts-config.xml, and 
> >>>>>>>>>>when the ActionServlet receives a request for
an action who's
> parameter
> >>>>>>>>>>                    
> >>>>>>>>>>
> >>>>>>>>>>is a tile definition name (such as .baseLayout),
I get the following
> >>>>>>>>>>          
> >>>>>>>>>>
> >>>>>>>>>>               
> >>>>>>>>>>
> >>>>>>>>>>                    
> >>>>>>>>>>
> >>>>>>exception:
> >>>>>>  
> >>>>>>
> >>>>>>       
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>>>>>>>javax.servlet.ServletException: Path .baseLayout
does not start with
> a 
> >>>>>>>>>>"/" character
> >>>>>>>>>>
> >>>>>>>>>>My action is defined like so:
> >>>>>>>>>>
> >>>>>>>>>>     <action
> >>>>>>>>>>         path="/US/tilestest"
> 
=== message truncated ===


__________________________________
Do you Yahoo!?
Exclusive Video Premiere - Britney Spears
http://launch.yahoo.com/promos/britneyspears/

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message