struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aas...@netzero.com
Subject Weblogic 8.1 - Error in using tag library
Date Wed, 17 Dec 2003 18:02:48 GMT
Environment:

OS: Windows XP
App Server: BEA Weblogic 8.1
MVC: Struts 1.1
IDE: JBuilder 7 Enterprise

JSP File:  See attachment

Error:
<Dec 17, 2003 9:34:42 AM MST> <Error> <HTTP> <BEA-101020> <[ServletContext(id=28941,name=hipaax,context-path=/hipaax)]
Servlet failed with Exception

weblogic.servlet.jsp.JspException: (line 1): 
=======================================================================
Error in using tag library uri='/WEB-INF/struts-html.tld' prefix='html': The Tag class 'org.apache.struts.taglib.html.BaseTag'
has no setter method corresponding to TLD declared attribute 'server', (JSP 1.1 spec, 5.4.1)
=======================================================================

I have checked the following:
1. Struts.jar is present in web-inf/lib
2. Taglib definitions (uri and location) present in web.xml
3. Struts tld files present under web-inf

I have also searched the BEA newsgroups for solutions in vain.

I use StrutsCX (XML/XSL) for the View part of MVC. So I am not familiar with tag libraries
and am unable to solve this problem after a day of searching the newsgroups/web. Your help
and time are greatly appreciated.

Thank you.

Aashra.

PS:Please let me know resources where I could get more information if this is a generic issue.





 


Mime
View raw message