struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shaun Roach" <sh...@wantcomputerhelp.com>
Subject Struts has problem finding getter
Date Wed, 17 Dec 2003 20:14:26 GMT
Sorry for resending this, I forgot to put a descriptive subject:

Hello, I have been using struts for awhile, but after I started a new project last week, I
began having a problem with it.

It seems like struts cannot find the getter methods in my beans.  For instance, when I try
the following jsp page:

<html:html>
 <logic:iterate id="statLine" name="playerDisplay" property="playerStats"   type="com.rototheory.beans.StatLine">
    <br>
    <bean:write name="statLine" property="lineDate"/>
 </logic:iterate>
</html:html>


Nothing is generated, ( suggesting that it didn't find the lineDate getter ).
However, if I use the following code:

<html:html>
 <logic:iterate id="statLine" name="playerDisplay" property="playerStats"   type="com.rototheory.beans.StatLine">
    <br>
    <%= statLine.getLineDate() %>
 </logic:iterate>
</html:html>


The correct output is generated.  I am having similar problems with struts finding collections
that I am trying to iterate over.  Does anyone have any idea of what might be causing the
struts to not find my bean's getters?

Thanks for your help,

Shaun Roach

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message