struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@blueyonder.co.uk>
Subject Re: client-side validation not working
Date Fri, 13 Feb 2004 14:41:50 GMT
Everything looks OK to me.

Have you checked what javascript is being generated - use "view source" in
your browser when you are looking at the page. is there a
validateActivityViewForm() method and is that method doing the validations
you expect?

A second thought is how are you submitting your page - I had problems when I
was using javascript with a link tag. If your doing that, then try putting
an ordinary submit button on the page and see if that works.

<html:submit>Save</html:submit>

Niall


----- Original Message ----- 
From: "Anderson, James H [IT]" <james.h.anderson@citigroup.com>
To: "Struts Users Mailing List" <struts-user@jakarta.apache.org>
Sent: Friday, February 13, 2004 2:23 PM
Subject: client-side validation not working


Server-side validation is working fine, but I can't seem to get client-side
working.

I know I must be doing something wrong, but I can't figure out what it is
:-(

Here's a bit of the tile that uses validation:

<%@ taglib uri="/tags/struts-bean" prefix="bean" %>
<%@ taglib uri="/tags/struts-html" prefix="html" %>
<%@ taglib uri="/tags/struts-logic" prefix="logic" %>

<html:form action="/SelectActivity" onsubmit="return
validateActivityViewForm(this)">
    <TABLE border="0" cellspacing="0" cellpadding="0" align="center">
...
          <html:text property="starting" value="" size="10"/>
...
          <html:text property="ending" value="" size="10"/>
...
     <logic:messagesPresent>
        <html:messages id="error">
          <TR><TD><FONT color="red"><STRONG><bean:write
name="error"/></STRONG></FONT><TD><TR>
        </html:messages>
      </logic:messagesPresent>
    </TABLE>
</html:form>
<html:javascript formName="ActivityViewForm"/>

Here's the piece of validation.xml:

    <formset>

      <form name="ActivityViewForm">
        <field
           property="starting"
           depends="date">
          <arg0 key="ActivityViewForm.starting.displayname"/>
        </field>
        <field
           property="ending"
           depends="date">
          <arg0 key="ActivityViewForm.ending.displayname"/>
        </field>
      </form>

    </formset>

Here's the Action entry from struts-config:

    <action
       path="/SelectActivity"
       name="ActivityViewForm"
       type="portfolio.SelectActivityAction"
       input=".activity.detail"/>


ActivityViewForm extends PortfolioForm which is declared thusly:

public class PortfolioForm extends ValidatorForm implements Serializable {

As I said, server-side validation is working fine, but the javascript on the
client-side isn't getting activated.

I hope someone can help me to resolve this quickly!

Thanks very much,

jim




---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message