struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <maili...@matthias-wessendorf.de>
Subject RE: Problem with Data Source Definition
Date Tue, 20 Apr 2004 05:58:46 GMT
Ralf,

did you add common-pools.jar 
http://jakarta.apache.org/commons/pool/

to WEB-INF/lib ?

i had a time ago a similar problem,
but after that it works

cheers,
matthias

> -----Original Message-----
> From: Ralf Schneider [mailto:ralf@tapfere-schneiderleins.de] 
> Sent: Tuesday, April 20, 2004 12:40 AM
> To: Struts Users Mailing List
> Subject: Problem with Data Source Definition
> 
> 
> Hi,
> 
> I'm trying to setup Struts 1.1 with a database connection 
> using DBCP 1.1 to 
> connect to a SAP DB 7.4 database.
> 
> Unfortunately, I get the following error during startup of 
> Tomcat (5.0.19): StandardContext[/demo_03]Servlet /demo_03 
> threw load() exception
> javax.servlet.UnavailableException: Initializing application 
> data source 
> local_01
> 	at 
> org.apache.struts.action.ActionServlet.initModuleDataSources(A
> ctionServlet.java:1091)
> 	at 
> org.apache.struts.action.ActionServlet.init(ActionServlet.java:472)
> 	at javax.servlet.GenericServlet.init(GenericServlet.java:256)
> 
> This is the data sources part of my struts-config.xml:
>   <data-sources>
>     <data-source key="local_01" 
> type="org.apache.commons.dbcp.BasicDataSource">
>       <set-property property="description" value="My DB 
> Configuration" />
>      
>       <set-property property="driverClassName" 
> value="com.sap.dbtech.jdbc.DriverSapDB" />
>       <set-property property="url" 
> value="jdbc:sapdb://localhost/ENIWDB" />
>       <set-property property="user" value="test" />
>       <set-property property="password" value="Test" />
>      
>       <set-property property="defaultAutoCommit" value="false" />
>       <set-property property="defaultReadOnly" value="false" />
>       <set-property property="maxActive" value="10" />
>       <set-property property="maxWait" value="5000" />
>       <set-property property="validationQuery" value="SELECT 
> COUNT(*) FROM 
> dual" />
>     </data-source>
>   </data-sources>
> 
> The same connection settings work in another project not 
> using Struts and 
> DBCP. Any ideas what the problem is with this configuration?
> 
> Thanks in advance,
> Ralf.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message