struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shyamal Shah" <shyamal_s...@hotmail.com>
Subject RE: How to use frames in Struts framework?
Date Mon, 12 Apr 2004 18:15:45 GMT
nevermind folks..it was a wrong URL..


>From: "Shyamal Shah" <shyamal_shah@hotmail.com>
>Reply-To: "Struts Users Mailing List" <user@struts.apache.org>
>To: user@struts.apache.org
>Subject: How to use frames in Struts framework?
>Date: Mon, 12 Apr 2004 12:37:56 -0400
>
>I am trying to load a frame page in Struts but unfortunately it is not 
>working. It is opening the frames page alright if I dont specify any source 
>for frames but if I do specify it it is not finding the page. I am getting 
>the following error message on my top frame :
>
>"Error 404--Not Found
>>From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
>10.4.5 404 Not Found
>The server has not found anything matching the Request-URI. No indication 
>is given of whether the condition is temporary or permanent.
>
>If the server does not wish to make this information available to the 
>client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) 
>status code SHOULD be used if the server knows, through some internally 
>configurable mechanism, that an old resource is permanently unavailable and 
>has no forwarding address."
>
>
>My frames page looks like this:
>
><frameset  rows="50%,*">
>    <frame name="ReviewResult" src="/showreview.do" marginwidth="10" 
>marginheight="10" scrolling="auto" frameborder="0">
>    <frameset  cols="50%,*">
>        <frame name="" src="" marginwidth="10" marginheight="10" 
>scrolling="auto" frameborder="0">
>        <frame name="" src="" marginwidth="10" marginheight="10" 
>scrolling="auto" frameborder="0">
>    </frameset>
></frameset>
>
>As you can see, on my top frame I am sourcing frame to /showreview.do. Here 
>is my entry for showreview in struts config and tiles file.
>
>struts-config.xml
>
><action
>    path="/showreview"
>    type="......ReviewResultAction" (actual action path)
>    name="ReviewResultForm"
>    scope="request"
>    validate="false">
>    <forward name="success" path=".b3.showreview"/>
></action>
>
>and in my tiles-defs.xml
>  <definition name=".b3.showreview" path="/b3/svo/ReviewResult.jsp"/>
>
>Can anyone tell me why it is not opening the page in frame properly? If I 
>open the page /showreview directly from the browser it opens successfully.
>
>
>Thanks,
>
>_________________________________________________________________
>Tax headache? MSN Money provides relief with tax tips, tools, IRS forms and 
>more! http://moneycentral.msn.com/tax/workshop/welcome.asp
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>For additional commands, e-mail: user-help@struts.apache.org
>

_________________________________________________________________
Limited-time offer: Fast, reliable MSN 9 Dial-up Internet access FREE for 2 
months! 
http://join.msn.com/?page=dept/dialup&pgmarket=en-us&ST=1/go/onm00200361ave/direct/01/


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message