struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Behrens" <jan.behr...@daxcolog.de>
Subject RE: NEWBIE: Wierd problem - Action sometimes produces Status 500 - No Context configured to process this request
Date Wed, 30 Jun 2004 09:10:44 GMT
Hi Adam,

I am new to Struts so this is more of a shot in the dark but anyway... Could
it be that the problem is that you only have one global forward pointing to
your login? So from a controll flow point of view wouldn't that mean that
you can only access login.do as an entry to your system? Have you tried
adding a global forward for your help.do as well?

Cheers, Jan

-----Original Message-----
From: Adam Lipscombe [mailto:adam.lipscombe@expensys.com] 
Sent: Tuesday, June 29, 2004 7:31 PM
To: 'Struts Users Mailing List'
Subject: NEWBIE: Wierd problem - Action sometimes produces Status 500 - No
Context configured to process this request


Folks,


I have a strange problem that is confusing me:

I have a simple login page with a Help button defined like this:

<html:link href="javascript:displayHelp('loginPage')"%>"<img border="0"
height="28" name="Image10" src="images/b_help_1.gif" width="32"></html:link>


When pressed, the JavaScript displayHelp() method below is called:

function displayHelp(context)
{
 [snip]

  var url = "<html:rewrite page='/help.do' />"  
  url += "?context=" + context;

 [snip]

  window.open(url, "HelpWindow", windowOptions);
}



This page is the first page that the user sees, having been redirected from
index.jsp like this:

<logic:redirect forward="login"/>




The problem is that before a user logs in, pressing the "Help" button
results in the error "HTTP Status 500 - No Context configured to process
this request" being displayed. 

However after a user logs in (and presses the browser back button to return
to the login page) the link works fine and the help is displayed OK.


Its as if the act of logging in sets up a context within which the actions
work....



The relevant bits of my struts-config looks like this:

<global-forwards>
    <forward name="login" path="/pages/Login.jsp" /> </global-forwards>

<action-mappings>
 <action input="/pages/Login.jsp" name="loginActionForm" path="/login"
scope="request" type="com.expensys.expensyswt.struts.action.Login"
validate="true">
   <forward name="home" path="/pages/Home.jsp" />
 </action>

 <action path="/help" scope="request"
type="com.expensys.expensyswt.struts.action.DisplayHelp" validate="false" >
  <forward name="loginHelp" path="/pages/help/LoginHelp.jsp" />
  <forward name="displayHelpTopics" path="/pages/help/HelpTopics.jsp" />
</action> </action-mappings>



Does anyone know what is going on here?
Why does the "/help.do" action URL work after the user has logged in but not
before? 
Is it to do with the fact that no action has been called before the log in
takes place?



TIA - Adam



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message