struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Mitchell" <jmitch...@apache.org>
Subject Re: Hidden Variables
Date Fri, 04 Jun 2004 12:26:43 GMT
The reason I asked that is because I have found that some users seem to
think that they can bookmark pages after submitting a form.  Not sure if
this is what you are seeing, but most of the time, and this is browser
dependent, the saved bookmark will not repost the page, but merely send the
URL, so unless you specify your forms as GET, you may see strange results in
your logs.

Best bet for ruling this out would be to put together some tests.

--
James Mitchell
Software Engineer / Open Source Evangelist
EdgeTech, Inc.
678.910.8017
AIM: jmitchtx


----- Original Message -----
From: "Joshi, Naveen" <naveen.joshi@jpmefs.com>
To: "Struts Users Mailing List" <user@struts.apache.org>
Sent: Thursday, June 03, 2004 9:47 AM
Subject: RE: Hidden Variables


It was based on log files that we found this error. This has happened for
couple of screens. It will work through out well, pass all the variables
properly and all of a sudden it will not pass one such varaible whereas all
other variables will be passed in the same screen. This is killing me. We
use Internet explorer(5.5 or above) and Netscape(4.7 or above). I have never
seen any user reporting the errors while using Netscape so I'am assuming
that it is a browser error. The difficult part is we are not able to
replicate the same scenario as this occurs once in a blue moon. Moreover
this has happened when there are few or more concurrent users. Wanted to
know if any of you have got the similar error. If there is a possible
solution please let me know.

Thanks


-----Original Message-----
From: James Mitchell [mailto:jmitchell@apache.org]
Sent: Thursday, June 03, 2004 7:28 AM
To: Struts Users Mailing List
Subject: Re: Hidden Variables


How do you know it is 1 in 300?  Is that based on tests or on browsing log
files?



--
James Mitchell
Software Engineer / Open Source Evangelist
EdgeTech, Inc.
678.910.8017
AIM: jmitchtx




----- Original Message -----
From: "Joshi, Naveen" <naveen.joshi@jpmefs.com>
To: "Struts Users Mailing List" <user@struts.apache.org>
Sent: Wednesday, June 02, 2004 8:10 AM
Subject: RE: Hidden Variables


I use Post method.

-----Original Message-----
From: news [mailto:news@sea.gmane.org]On Behalf Of Lionel
Sent: Wednesday, June 02, 2004 5:24 AM
To: user@struts.apache.org
Subject: Re: Hidden Variables


Joshi, Naveen wrote:
> All,
>
> one out of 300 times my hidden variable would not set to form. Any
> ideas what could be the issue.

do you use get or post method to send your form ?




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message