struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Hill" <andrew.david.h...@gridnode.com>
Subject RE: session problem
Date Fri, 11 Jun 2004 09:34:14 GMT
The servlet container will try to encode this sessionId in a cookie if it
can (saving the need to rewrite links) so you may wish to check the browser
settings to see if cookies are enabled. (Its best to make sure you use the
html:rewrite tag (or equivelent) for your links though so that your app will
support users when they have cookies disabled).

-----Original Message-----
From: nikhil walvekar [mailto:walvekarnikhil@yahoo.co.in]
Sent: Friday, 11 June 2004 17:34
To: Struts Users Mailing List
Subject: Re: session problem


Hi,
same thing i have experienced with IE 6.0, it will work with mozilla
Problem is that with each request session id is not passed.
You need to explicitly pass it as url parameter.
http://dbomis.com/anyLink;jsessionid=A0698B81A1F1AA2B1ECDA19B0ACFD6E2


Nikhil

Shailender Jain <shailender.jain@teleatlas.com> wrote:
I am using session object in my application to validate whether the user
is valid or not.

I am doing this in the processPreprocess() method of RequestProcessor.
But in I.E. 6.0 update version: SP1, the session object becomes null.
So once user click at any link in the application he gets logged out.

The system admin has also done the following configuration


1. I installed the application on a machine having the IP
(10.1.252.41). The system admin made a virtual IP (10.1.252.42) and
gave me a DSN "dbomis.com" which can be used to access the
application. This DSN points to virtual IP.
2. Now when i access the application using http://10.1.252.41/ or
"http://10.1.252.42/" in IE 6.0 SP1 then it works ok.
3. When i use the "http://dbomis.com/" then the login page come. User
is able to login (processPreprocess() method does not check for
session while user is logging in). But when the user clicks on any
link the session becomes null so the user is logged out of the
application. This problem happens only on I.E. update version SP1.
On I.E 5.5 this url works ok.

Anyone has got any idea why this must be happening






Yahoo! India Matrimony: Find your partner online.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message