struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ra...@vmoksha.com
Subject RE: Struts, War files, and WebLogic
Date Fri, 11 Jun 2004 08:55:22 GMT
I dont think it's a security issue...coz if it is, then weblogic should 
have thrown some security related exception.

I too suspect it as a configuration problem.

regds
r-a-v-i




Mick.Knutson@wellsfargo.com
06/11/2004 03:19 AM
Please respond to Struts Users Mailing List

 
        To:     user@struts.apache.org
        cc: 
        Subject:        RE: Struts, War files, and WebLogic


Sounds like you have a security realm on WebLogic that is causing this.
Is this a fresh install?

-----Original Message-----
From: David Meyer [mailto:David.Meyer@sas.com]
Sent: Thursday, June 10, 2004 1:44 PM
To: struts-user@jakarta.apache.org
Subject: Struts, War files, and Weblogic


I have a war file that I am trying to deploy on Weblogic 8.1.  I am able 
to
deploy and access jsp's within the WAR file.  However, when a Struts 
action
is requested, i.e. http://server/someAction.do, I get the following
NullPointerException:

java.lang.NullPointerException
at
org.apache.struts.action.ActionServlet.parseModuleConfigFile(ActionServlet.j
ava:1003)
at
org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:9
55)
at org.apache.struts.action.ActionServlet.init(ActionServlet.java:470)
at javax.servlet.GenericServlet.init(GenericServlet.java:258)
at
weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run(ServletStubI
mpl.java:1070)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubjec
t.java:317)
at 
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:97)
at
weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java
:893)
at
weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.ja
va:842)
at
weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.jav
a:782)
at
weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.java:50
4)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java
:349)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java
:305)
at
weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(W
ebAppServletContext.java:6291)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubjec
t.java:317)
at 
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:97)
at
weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletCo
ntext.java:3575)
at
weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java
:2573)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:178)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:151)
 
It looks like that the Struts ActionServlet cannot find my struts config
files, even though they are in the correct location within the war file.

What's really odd is if I unwar and deploy the app as an exploded 
directory,
everything works fine, including the Struts pages.  Any ideas?

Thanks for the help,

David Meyer

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message