struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From J Jones <jjo...@gltg.com>
Subject Precompile JSP error with html:messages
Date Wed, 09 Jun 2004 11:49:44 GMT
I have the following JSP:
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>

<html>
  <head>
    <title>test</title>
  </head>
  <body>
	<html:messages id="errorMsg" message="true" bundle="WebGeneral">
	    <font color="red"><bean:write name="errorMsg"/></font><br/>
	</html:messages>
  </body>
</html>

When I deploy an ear file into either WSAD or WebSphere admin console and check 
the precompile JSP box, the JSP compiler gives the following error:
[6/9/04 7:34:41:108 EDT] 40e0e85a SystemErr     R 
C:/DOCUME~1/jjones/LOCALS~1/Temp/app_fd092f8e4b/ear/brochureWAR.war/WEB-
INF/classes/_test.java:82: cannot resolve symbol
symbol  : method setMessage  (java.lang.String)
location: class org.apache.struts.taglib.html.MessagesTag
[6/9/04 7:34:41:139 EDT] 40e0e85a SystemErr     R         
_jspx_th_html_messages_0.setMessage("true");
[6/9/04 7:34:41:139 EDT] 40e0e85a SystemErr     
R                                 ^
[6/9/04 7:34:41:327 EDT] 40e0e85a SystemErr     R 1 error

The JSP compiles just fine while developing in WSAD or and it runs fine if I 
deploy the ear without precompiling the JSPs.  

Any ideas?

Thanks,
Jennifer



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message