struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gurjinder Bal" <jin...@hotmail.com>
Subject Re: Plugin problem upgrading 1.1 --> 1.2.4
Date Mon, 04 Oct 2004 16:45:30 GMT
I don't think that there is anything goin wrong in between.  The strange 
thing is that the init() method gets called but the debug on the properties 
shows null for both:


  public void init(ActionServlet parm1, ModuleConfig parm2) throws 
javax.servlet.ServletException {
        DigesterDriver digester = new DigesterDriver();
        try {

            logger.debug("businessDelegatesPath - "+businessDelegatesPath);
            logger.debug("digesterRulesPath - "+digesterRulesPath);
            InputStream input = 
parm1.getServletContext().getResourceAsStream(businessDelegatesPath);
.......

so the plugin gets called but the setter for the props never get called as i 
have debug in them too which never show up in the logs:

When i downgrade everything to 1.1 it works.

>From what you've said I'm [retty sure tha I messing something up in the 
config.  here is the servlet config for good measure TIA

  <servlet>
    <servlet-name>action</servlet-name>
    <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
    <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/struts-config.xml</param-value>
    </init-param>
    <init-param>
      <param-name>convertNull</param-name>
      <param-value>true</param-value>
    </init-param>
    <init-param>
      <param-name>debug</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>detail</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>validate</param-name>
      <param-value>true</param-value>
    </init-param>
   </servlet>



>From: "Niall Pemberton" <niall.pemberton@blueyonder.co.uk>
>Reply-To: "Struts Users Mailing List" <user@struts.apache.org>
>To: "Struts Users Mailing List" <user@struts.apache.org>
>Subject: Re: Plugin problem upgrading 1.1 --> 1.2.4
>Date: Mon, 4 Oct 2004 17:38:46 +0100
>
>I am using both the standard tiles and validator plugins plus some custom
>Plugins of my own in Struts 1.2.4 and have had no problems at all with the
>upgrade from 1.1.
>
>Are you sure something else isn't going wrong first when you app starts up
>so that the PlugIn initialization isn't even being reached. Check the logs.
>
>Notes on upgrading are here:
>
>    http://wiki.apache.org/struts/StrutsUpgrade
>
>
>Niall
>
>----- Original Message -----
>From: "Gurjinder Bal" <jinbal@hotmail.com>
>To: <user@struts.apache.org>
>Sent: Monday, October 04, 2004 5:10 PM
>Subject: Plugin problem upgrading 1.1 --> 1.2.4
>
>
> > Hi,
> >
> > When upgrading from from 1.1 to 1.2.4 the plugin element in the
> > struts-config seems to start malfunctioning in tha thte set-property
>ceases
> > to function.  The setters for the properties never get called.
> >
> > here is the plugin entry:
> >   <plug-in className="com.buyacar.config.ConfigPlugin">
> >     <set-property property="businessDelegatesPath"
> > value="/WEB-INF/businessdelegateconfig.xml" />
> >     <set-property property="digesterRulesPath"
> > value="/WEB-INF/configrules.xml" />
> >   </plug-in>
> >
> > here are the property namea in my config implementation (they have 
>setters
> > too):
> >
> > public class ConfigPlugin implements PlugIn {
> >     private static Logger logger = Logger.getLogger(ConfigPlugin.class);
> >     private String businessDelegatesPath = null;
> >     private String digesterRulesPath = null;
> > ........
> >
> > this works fine under 1.1 but does the setters do not get called under
>1.2.4
> >
> > I believe that the TilesPlugin is also being affected - but cannot debug
>to
> > make sure.
> >
> > Is anybody else affected oir is there some gotcha that i need to be 
>aware
>of
> > when upgrading.
> >
> > cheers
> >
> > Jin Bal
> >
> > _________________________________________________________________
> > Stay in touch with absent friends - get MSN Messenger
> > http://www.msn.co.uk/messenger
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> > For additional commands, e-mail: user-help@struts.apache.org
> >
> >
> >
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>For additional commands, e-mail: user-help@struts.apache.org
>

_________________________________________________________________
Express yourself with cool new emoticons http://www.msn.co.uk/specials/myemo


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message