struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Morales de Frías, David <dmdefr...@indra.es>
Subject RE: request between actions
Date Wed, 01 Dec 2004 09:54:31 GMT
Thanks for your help, but it's still not working.

i've changed struts config, from redirect="true" (ops..) to redirect="false". And it's supossed
that i will have my request's parameters in second action, but it isn't true. I don's see
any parameters...

What is the error??

Best regards



-----Mensaje original-----
De: Ram Venkataswamy [mailto:ramv@m7.com]
Enviado el: martes, 30 de noviembre de 2004 21:33
Para: Struts Users Mailing List
Asunto: RE: request between actions


Set to "true" if a redirect instruction should be issued to the user-agent so that a new request
is issued for this forward's resource. If true, RequestDispatcher.Redirect is called. If "false",
RequestDispatcher.forward is called instead. [false]. 

 

The culprit is redirect=true - check the definition above 

 

 

-----Original Message-----
From: Morales de Frías, David [mailto:dmdefrias@indra.es] 
Sent: Tuesday, November 30, 2004 12:17 PM
To: user@struts.apache.org
Subject: request between actions

 

Hi all¡¡

 

I need your help, please.

 

I have an action that forwards to another action, and i'm loosing request parameters.

 

I have in struts-config this lines:

 

<forward name="xxx" redirect="true" path="/Xxxx.do" />

 

but it doesn't work.

 

Can you help me?


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message