struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Ziemer <t.zie...@dkfz-heidelberg.de>
Subject Re: Problems using JSTL with struts
Date Fri, 18 Mar 2005 10:00:22 GMT
Hi,

I had a similar problem. What I did was:
a) put jstl.jar and standard.jar in WEB-INF/lib
b) modify your web.xml - it should start with this line:

<web-app xmlns="http://java.sun.com/xml/ns/j2ee" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee web-app_2_4.xsd" 
version="2.4">

When I used my "old" web.xml with "web-app_2_2.dtd", it didn't work. Can 
anybody explain this?

Regards,

Tom

Rodolfo GarcĂ­a Esteban/CYII wrote:
> Hi,
> 
> I have a little application done with struts 1.2 and hibernate 2.1, I want 
> to migrate it to JSTL 2.0, and struts-EL. I have done the next:
> 
> 1. Install jstl, adding to the WEB-INF/lib jstl.jar 
> 2. Writing in the pages then taglib clause to import the tags.
> 
> But I have the next problems.
> 
> 1 when I do <c:set > for get the actionForm return null, I can manage the 
> form.
> 2. when I do <c:out  value=${xxxx}....,  in then web I don't see then 
> content of xxxx, I see as a literal "${xxxx}".
> 
> Has somebody use JSTL and Struts-EL with Struts 1.2? Do somebody knows the 
> solution for my problem?
> 
> I would apreciatte any help
> 
> Best regards
> 
> Rodolfo
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message