struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curtis Taylor <curtis...@gmail.com>
Subject Re: One last ATTACHMENT issue
Date Wed, 02 Mar 2005 04:31:42 GMT
Shot in the dark here:

IIRC, you don't need the ampersand after the initial question mark in 
the request URL. Try killing that & see what happens...

Good luck,

-- Curtis

Eric Lemle wrote:
> Can anyone tell me why this....
> 
>  <a href="/physrcrtadmin/AttachmentAction.do?&amp;attachment_id=341"
> target="ResumeAttachment">VeselovaNataliaECV.doc</a>
> 
> ....works perfectly.
> 
> 
> But this.....
> 
> function printAttachment( id, name )
> {
>   childWindow=window.open( 'AttachmentAction.do?&attachment_id='+id,
> name,
> 'toolbar=no,location=no,directories=no,status=yes,menubar=no,resizable=yes,copyhistory=no,scrollbars=yes,width=790,height=600');
>   childWindow.focus();
> }
> which is called with...
> 
> if(document.forms[0].printCV.checked==true ||
> document.forms[0].printAllAttachments.checked==true) {
>   printAttachment( '341', 'printCV');
>   }
> 
> ....throws an error messages saying it can find the file.
> 
> 
> ?
> 
> 
> 
> 
> Eric D. Lemle
> Senior Programmer / Analyst
> Intermountain Health Care
> 36 South State Street, Suite 1100
> Salt Lake City, Utah 84111 
> United States of America (USA)
> (801) 442-3688 -- e-mail: Eric.Lemle@IHC.com


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message