struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dakota Jack <dakota.j...@gmail.com>
Subject Re: Help With Action
Date Fri, 11 Mar 2005 18:03:57 GMT
The color of the page is not that helpful.  Code packed pages can be
white.  Is there any code on the page?  Have you checked the HTML
source code?   What's there?  When you know that, then you have some
data to work with.

Jack




On Fri, 11 Mar 2005 10:22:29 -0600, Scott Purcell
<spurcell@vertisinc.com> wrote:
> I guess I could do that, but the docs state that if the validation fails, request will
go to the "input" tag. and I do not see how to do a redirect on that.
> 
> Anyone?
> 
> Scott
> 
> -----Original Message-----
> From: Schuster Joel M Contr ESC/NDC [mailto:Joel.Schuster@cisf.af.mil]
> Sent: Friday, March 11, 2005 10:16 AM
> To: 'Struts Users Mailing List'
> Subject: RE: Help With Action
> 
> <forward name="Failure" path="/jsp/login.jsp" redirect="true" />
> 
> ?? maybe ??
> 
> -----Original Message-----
> From: Scott Purcell [mailto:spurcell@vertisinc.com]
> Sent: Friday, March 11, 2005 9:13 AM
> To: user@struts.apache.org
> Subject: Help With Action
> 
> Hello,
> 
> I have the following action setup in my struts-config.xml file:
> 
>  <action
>     path="/login"
>     input="/dealer/jsp/login.jsp"
>     type="com.ddi.dealer.action.LoginAction"
>     name="loginBean"
>     scope="request"
>     validate="true">
>     <forward name="Success" path="/jsp/welcome.jsp" />
>     <forward name="Failure" path="/jsp/login.jsp" />
>   </action>
> 
> I am failing the ActionForm so my request should go to the "input" tag. And
> according to the Logger it does.
> 2005-03-11 10:12:12,349 INFO com.ddi.dealer.bean.LoginForm - XXX setting
> username=
> 2005-03-11 10:12:12,349 DEBUG org.apache.struts.action.RequestProcessor -
> Validating input form properties
> 2005-03-11 10:12:12,349 INFO com.ddi.dealer.bean.LoginForm - Validate called
> on LoginForm
> 2005-03-11 10:12:12,350 DEBUG org.apache.struts.action.RequestProcessor -
> Validation failed, returning to '/dealer/jsp/login.jsp'
> 
> But for whatever reason, the page only displays white with no error? I feel
> that it needs to do a redirect or something, but not sure how that should
> work. Does anyone have any ideas what I am doing wrong?
> 
> Thanks,
> 
> Scott K Purcell | Developer | VERTIS |
> 555 Washington Ave. 4th Floor | St. Louis, MO 63101 |
> 314.588.0720 Ext:1320 | spurcell@vertisinc.com | http://www.vertisinc.com
> <http://www.vertisinc.com/>
> 
> Vertis is the premier provider of targeted advertising, media, and
> marketing services that drive consumers to marketers more effectively.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 


-- 
"You can lead a horse to water but you cannot make it float on its back."
~Dakota Jack~

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message