struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vince Law" <vince....@ascertane.com>
Subject Empty values for all the ActionForm's attribute
Date Sat, 01 Oct 2005 01:05:15 GMT
Hi All,

I am having a problem with ActionForm.  I have spent quite some time to
tackle the problem, but without any luck resolving it.  The problem is.

I have three Actions which share the same ActionForm.  They all work
perfectly fine, until in one of the Action's excecute method, a Httpclient
call is made to a different URL (a third party software) to retrieve some
data from the internet.  Then, from that time on, all the property from the
ActionForm is null.  But when I tried to access the value directly from the
"request" object, the value is there, e.g:

public ActionForward execute(ActionMapping mapping, ActionForm form,
HttpServletRequest request, HttpServletResponse response)
{

   MyForm myForm = (MyForm)form;

   myForm.getSomeThing();              //returned "empty"
   request.getParameter("someThing");  //returned some "value"

   .......
}

The ActionForm is defined in the action with the scope="request".
The Struts version is 1.2.7.

I hope some of you can give me some insight into it, I can't figure out how
to resolve it myself.

Thank you so much in advance!

Sincerely,
Vince






---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message