struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Reumann <strut...@reumann.net>
Subject Re: problem deploying "rr-struts-nested.war"
Date Wed, 04 Jan 2006 15:30:18 GMT
Srinivas Jadcharla wrote the following on 1/4/2006 9:58 AM:
> Hi Rick,
> 
> Iam getting the following problem
> 
> [image: Error]The EAR file could be corrupt and/or incomplete.
> com.ibm.etools.archive.exception.DeploymentDescriptorLoadException:
> WEB-INF/web.xml
> 
> while iam trying to deploy rr-struts-nested.war
>  from http://www.reumann.net/tech/struts-nested.jsp   on Websphere 5.1.1

Did you try rebuilding the app yourself from the source using the build 
file? Those wars were built with Java 1.5, although I just decided to 
rebuild it with Java 1.4 and deployed it to Tomcat 5.0 and it's working 
fine there. I uploaded that war so give it a try and let me know how it 
goes. (When I get home later, I'm going to rebuild with 1.5 though.)

I've noticed odd things when the wars are built with different Java 
versions and then deployed to different servers. Maybe someone can 
correct me here, but I swear I've notice problems for example when I've 
compile and built a war with Java 1.5 and then tried to deploy it to 
Tomcat 5.0 that was being run with Java 1.4.

Try using the build file on your local machine and deploy to Websphere 
and let me know how that works.

Thanks

-- 
Rick
http://www.tech.reumann.net
(Struts lessons, articles, etc.)

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message