struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rafael" <rafael.tats...@gmail.com>
Subject Re: [Struts + Tiles] JSTL problem on WebSphere Application Server 6
Date Sun, 04 Jun 2006 05:01:18 GMT
actually WAS6 comes with JSTL libraries, so the jars with TLDs are located 
inside WAS6 lib directory.
If I include the taglib directive (<%@ taglib 
uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>) all jstl tags in the 
jsp page works perfectly, but If I include this same directive into a new 
jsp page and use <%@ include tag to include this new jsp page into the jsp 
page that I want to use jstl tags, all jstl pages stopped to work.



-Rafael T Icibaci


----- Original Message ----- 
From: "Martin Gainty" <mgainty@hotmail.com>
To: "Struts Users Mailing List" <user@struts.apache.org>
Sent: Saturday, June 03, 2006 10:15 AM
Subject: Re: [Struts + Tiles] JSTL problem on WebSphere Application Server 6


> also.. are the tld files located in WEB-INF?
> HTH,
> Martin --
>
> This email message and any files transmitted with it contain confidential
> information intended only for the person(s) to whom this email message is
> addressed.  If you have received this email message in error, please 
> notify
> the sender immediately by telephone or email and destroy the original
> message without making a copy.  Thank you.
>
> ----- Original Message ----- 
> From: "Samere, Adam J" <asamere@paychex.com>
> To: "Struts Users Mailing List" <user@struts.apache.org>
> Sent: Friday, June 02, 2006 11:36 AM
> Subject: RE: [Struts + Tiles] JSTL problem on WebSphere Application Server 
> 6
>
>
> I doubt that the include is not working. What version of JSTL are you
> using? Do you have taglib entries in web.xml?
>
> Can you explain "JSTL stopped working" a little more extensively?
>
> -----Original Message-----
> From: Rafael [mailto:rafael.tatsuya@gmail.com]
> Sent: Friday, June 02, 2006 11:01 AM
> To: Struts Users Mailing List
> Subject: [Struts + Tiles] JSTL problem on WebSphere Application Server 6
>
> Hi Guys,
>
> I've an application that uses Struts and Tiles, this application was
> running on WebSphere 5.1 for almost 3 years but now when we moved to
> WAS6 JSTL stopped working. Let me give an example:
>
> we've a jsp page called taglibs.jsp, in this jsp page we've all the
> struts, jstl taglibrary imports. So, when we need struts or JSTL in
> another JSP page we just include this taglibs.jsp. Using -> <%@ include
> file="/jsp/taglibs.jsp" %> , seems that WAS6 container support JSP 2.0
> and somehow this caused the include directive to stop working. I found a
> lot of messages in Forums and after I read the JSP 2.0 spec, I decided
> to set encoding to each page. Isn't worked because actually include
> directive includes content like-> <p> Content </p> but don't include
> taglib directives like the one below.
> <%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>
>
>
> Any ideias ?
>
> Thanks !!
>
> -Rafael T Icibaci
>
>
> -----------------------------------------
> The information contained in this message may be privileged,
> confidential, and protected from disclosure. If the reader of this
> message is not the intended recipient, or any employee or agent
> responsible for delivering this message to the intended recipient,
> you are hereby notified that any dissemination, distribution, or
> copying of this communication is strictly prohibited. If you have
> received this communication in error, please notify us immediately
> by replying to the message and deleting it from your computer.
>
> Thank you. Paychex, Inc.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message