struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bart Busschots <b...@cs.nuim.ie>
Subject Re: Email validation doesn't work
Date Fri, 02 Jun 2006 13:15:47 GMT
Hi,

Your regular expression on the mask would seem to be problem. I presume 
you want it to match words that contain no = rather than what you have 
at the moment which forces ALL letters to be = which I'm sure doesn't work.

The RE you need is:

^[^=]+$

HTH, Bart.

marisol wrote:
> Can anybody help me with this?  THANKS!
> Marisol.
>
>
> With Struts Validator Framework, the following mail is valid ===aaa@aaa.com.
>
> I tried with the following but it doesn't work.
>
> <field property="email" depends="required, mask, email">
>     <msg name="mask" key="userRegistration.mailMask" />
>     <arg0 key="userRegistration.email" />
>         <var>
>             <var-name>mask</var-name>
>             <var-value>^[=]*$</var-value>
>         </var>
> </field>
>
> Anyone knows if there's a bug place or it's me doing something wrong???
>
> THANKS!
> Marisol.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message