struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Samere, Adam J" <asam...@paychex.com>
Subject RE: how do I use a LazyDynaBean as an ActionForm?
Date Tue, 11 Jul 2006 17:05:49 GMT
The class specified by the type attribute in your form bean must be a
concrete implementation of org.apache.struts.action.ActionForm (as the
signature of the Action.execute method indicates). 

You can create your own implementation of ActionForm backed by a
LazyDynaBean, or try org.apache.struts.validator.LazyValidatorForm.

-Adam

-----Original Message-----
From: Yanroy [mailto:rmeador@wpi.edu] 
Sent: Tuesday, July 11, 2006 12:39 PM
To: user@struts.apache.org
Subject: how do I use a LazyDynaBean as an ActionForm?


Hi,
You may recall I posted a message similar to this one several days ago.
I never received a reply, so I'm hoping that this shorter (and hopefully
simpler) version will get one.  I'm using a LazyDynaBean as the form
associated with a strut, which the docs seem to say will work by being
wrapped inside some other kind of ActionForm.  I haven't found any
examples online of exactly how to do this (none contain
struts-config.xml, strut and JSP all from the same app).  I'll give you
a couple lines from my
struts-config.xml:

<form-bean 
	name="AnalysisForm" 
	type="org.apache.commons.beanutils.LazyDynaBean">
	<form-property 
		name="runnableTables" 
		type="java.lang.Integer"
		initial="1" 
		/>
</form-bean>

I also specify some array fields in that bean, but I edited that out for
the sake of brevity.

I also have my action:

<action
			path="/AnalysisConfig"
			name="AnalysisForm"
	
type="org.assistment.apps.newReporting.analysis.struts.AnalysisConfig"
			scope="request"
			parameter="method">
</action>

The real problem here is that I have no idea how to get the data out of
the LazyDynaBean.  In my action strut, the form parameter passed to the
handler is null.  To me, this indicates some kind of misconfiguration,
but I can't see what it could be.  I'd greatly appreciate any help you
can give... this problem is completely holding up my work (it's the last
part of the webapp I'm making).

Thank you very much,
Ryan

PS - If anyone cares, my previous message was titled "ActionForm is null
when using dynabean"
--
View this message in context:
http://www.nabble.com/how-do-I-use-a-LazyDynaBean-as-an-ActionForm--tf19
25661.html#a5273110
Sent from the Struts - User forum at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


-----------------------------------------
The information contained in this message may be privileged,
confidential, and protected from disclosure. If the reader of this
message is not the intended recipient, or any employee or agent
responsible for delivering this message to the intended recipient,
you are hereby notified that any dissemination, distribution, or
copying of this communication is strictly prohibited. If you have
received this communication in error, please notify us immediately
by replying to the message and deleting it from your computer.

Thank you. Paychex, Inc.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message