struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stephan opitz" <stephan.op...@gmail.com>
Subject Re: [shale] + myeclipse + jboss + how to + working???
Date Sun, 02 Jul 2006 15:33:42 GMT
all depending libaries have to be copy in the WEB-INF/lib folder
resources in the src folder too...

it works

2006/7/2, stephan opitz <stephan.opitz@gmail.com>:
> 1. create a shale project using maven 2
>
> mvn archetype:create  -DarchetypeGroupId=org.apache.struts.shale
> -DarchetypeArtifactId=struts-archetype-shale-blank
> -DarchetypeVersion=1.0-SNAPSHOT -DgroupId=org.apache.struts.ShaleTest
> -DpackageName=org.apache.struts.ShaleTest -DartifactId=ShaleTest
> -DremoteRepositories=http://people.apache.org/maven-snapshot-repository
>
> 2. add eclipse project dependencies + maven repo
>
> mvn eclipse:eclipse
>
> mvn -Declipse.workspace=X:\workspace eclipse:add-maven-repo
>
> 3. open myeclipse with maven2 plugin
>
> activate maven 2 + update dependencies
>
> 4. add myeclipse webproject folder
>
> src/main/webapp
>
> 5. deploy + start
> deplay war file using myeclipse ide
>
> 6. start jboss 4
>
> exception is coming...
>
> deploying incomplete exception while starting...
>
> does exist there any possibility??
>
> only mvn cargo:start work from commandline -> with cargo tomcat plugin
> -> but jboss
>
> stephan
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message