struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian.Priest" <Ian.Pri...@opsera.com>
Subject [shale][clay] NullPointerException on Linux
Date Tue, 04 Jul 2006 14:13:04 GMT
Anyone want to hazard a guess as to why I get the npe below when I
deploy my application on Linux in tomcat 5?
I'd just upgraded shale and clay to the latest snapshot of 1.0.3 and
myfaces to 1.1.3. The same war file deploys and runs happily on my
windows development box running tomcat 5.5.12.
 
2006-07-04 13:10:36,446 ERROR
[org.apache.shale.clay.parser.builder.BuilderFactory]
java.lang.NullPointerException
2006-07-04 13:10:36,447 ERROR
[org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/scn].[f
aces]] Servlet.service() for servlet faces threw exception
java.lang.RuntimeException: java.lang.NullPointerException
        at
org.apache.shale.clay.parser.builder.BuilderFactory.getRenderer(BuilderF
actory.java:115)
        at org.apache.shale.clay.parser.Node.getBuilder(Node.java:239)
        at
org.apache.shale.clay.config.ClayTemplateParser.generateElement(ClayTemp
lateParser.java:126)
        at
org.apache.shale.clay.config.ClayTemplateParser.loadConfigFile(ClayTempl
ateParser.java:89)
        <...lines snipped...>
Caused by: java.lang.NullPointerException
        at
org.apache.shale.clay.parser.builder.BuilderFactory.getRenderer(BuilderF
actory.java:111)
        ... 48 more
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message