struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Friedman" <hum...@ix.netcom.com>
Subject RE: Validation problems: again...
Date Tue, 04 Jul 2006 17:12:54 GMT
Have you deleted your server's work directory to ensure that all new classes
are being invoked next time you run it?  And of course try it again before
replying.

Can you post all together:

a) Your complete related form bean mappings (from <... to /> for each
mapping, you can cut out any private domain portions of your class name)
b) Your complete related action mappings (from <... to /> for each mapping,
you can cut out any private domain portions of your class name)
c) The signature and return lines of your validate methods (contents not
required, only those lines)

Regards,
David

-----Original Message-----
From: Vinicius Carvalho [mailto:java.vinicius@gmail.com]
Sent: Tuesday, July 04, 2006 1:06 PM
To: Struts Users Mailing List
Subject: Re: Validation problems: again...

yes both of em, I've post a pice of the config file ;)
yes either, both has validate(ActionMapping arg0, HttpServletRequest
arg1) signature.
My struts version is 1.2.9.

Looking at the logs, for the action/form that just skip validation:
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-6148719]
RequestUtils.createActionForm(300) |  -->
com.synos.pbh.opdigital.view.form.votacao.CadastrarVotanteForm@edf7e9
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-6148719]
RequestProcessor.processActionForm(339) |  Storing ActionForm bean
instance in scope 'request' under attribute key 'cadastrarVotanteForm'
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-6148719]
RequestProcessor.processPopulate(805) |  Populating bean properties
from this request
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-6148719]
RequestProcessor.processValidate(948) |  Validating input form
properties
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-6148719]
RequestProcessor.processValidate(953) |   No errors detected,
accepting input


Well no errors detected? It does not even calls my validate method...

Now for the other action:

  [java] [OPDIGITAL] DEBUG [HttpRequestHandler-20077295]
RequestUtils.createActionForm(294) |  Creating new ActionForm instance
of type 'com.synos.pbh.opdigital.view.form.mailing.VisitanteForm'
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-20077295]
RequestUtils.createActionForm(300) |  -->
com.synos.pbh.opdigital.view.form.mailing.VisitanteForm@581ea2
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-20077295]
RequestProcessor.processActionForm(339) |  Storing ActionForm bean
instance in scope 'request' under attribute key
'cadastrarVisitanteForm'
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-20077295]
RequestProcessor.processPopulate(805) |  Populating bean properties
from this request
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-20077295]
RequestProcessor.processValidate(948) |  Validating input form
properties
     [java] [OPDIGITAL] DEBUG [HttpRequestHandler-20077295]
RequestProcessor.processValidate(980) |  Validation failed, returning
to '/cadastroVisitante.do'

This time, as the validate method is called, and it fails, i get the
proper message.

Dude I hate this little bugs, Im sure I missed something somewhere ...

Regards


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message