Do you have the property "page" being submitted with your form: Also, are you sure that the validation isn't working and the error messages aren't getting displayed? Can you send the jsp source? -Matt On 8/3/06, Bart Busschots wrote: > I'm either missing something stupid (which is always possible) or I've > managed to break the validator. I have an app that uses validator all > over the place and it's working fine in all my other actions but for > this one action it is simply not getting called. > > I can't see any difference between this action/form/validation and all > the other ones that are working. > > This is the form: > > type="org.apache.struts.validator.DynaValidatorForm"> > > > > > > > > This is the action: > > type="vtie.portal.mentor.CreateStudentGroupPrepareAction" > name="createStudentGroupForm" scope="session" validate="true" > input="/home/mentor/addStudentGroupForm.jsp"> > path="/do/mentor/createAnonymousStudentGroup" /> > path="/home/mentor/getStudentNamesForm.jsp" /> > > > > And this is the validation: > >
> > mask^[a-zA-Z]+[\w\ > ]*$ > > > > > > > > >
> > Can anyone see something obviously wrong there? > > Cheers, > > Bart. > > --------------------------------------------------------------------- > To unsubscribe, e-mail: user-unsubscribe@struts.apache.org > For additional commands, e-mail: user-help@struts.apache.org > > -- Matthew Kurjanowicz matt.kurjanowicz@gmail.com College of Computing GEORGIA Institute of TECHnology --------------------------------------------------------------------- To unsubscribe, e-mail: user-unsubscribe@struts.apache.org For additional commands, e-mail: user-help@struts.apache.org