struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Nesbitt <scottnesb...@yahoo.com>
Subject Cannot find Struts taglib
Date Fri, 02 Feb 2007 13:59:05 GMT

I am getting the following when I try to use the
taglib:

Servlet failed with Exception
java.lang.NullPointerException
        at
org.apache.struts2.views.jsp.TagUtils.getStack(TagUtils.java:56)
        at
org.apache.struts2.views.jsp.StrutsBodyTagSupport.getStack(StrutsBodyTagSupport.java:51)

Here is my entire Hello.jsp:

<%@ taglib prefix="s" uri="/struts-tags" %>
<html>
   <head>
      <title>Hello World!</title>
   </head>
   <body>
      <h2><s:property value="message"/></h2>
   </body>
</html>

I tried adding the following to my web.xml even though
it should not be necessary:

<taglib>
 <taglib-uri>/s</taglib-uri>
<taglib-location>/WEB-INF/struts-tags.tld</taglib-location>
</taglib>

and made sure the file was in my WEB-INF directory. 
The page renders without the s:property line.

Any suggestions?  I am using Weblogic 9.2 with
struts-2.0.1.

Thanks for any tips or pointers,

Scott


 
____________________________________________________________________________________
Don't get soaked.  Take a quick peak at the forecast
with the Yahoo! Search weather shortcut.
http://tools.search.yahoo.com/shortcuts/#loc_weather

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message