struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Saumets" <paul.saum...@merge-solutions.com>
Subject [S2] Sitemesh - FreeMarker configuration?
Date Thu, 01 Mar 2007 17:03:32 GMT
Could someone please tell me why JBOSS is giving me the following error when launching my application:

11:52:29,729 INFO  [STDOUT] 11:52:29,727 ERROR [[/xxxxxx]] Exception starting filter sitemesh
java.lang.NoClassDefFoundError: com/opensymphony/module/sitemesh/filter/PageFilter
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:620)

This is my web.xml configuration:

   <filter>
        <filter-name>struts2-cleanup</filter-name>
        <filter-class>
            org.apache.struts2.dispatcher.ActionContextCleanup
        </filter-class>
    </filter>
     <filter>
        <filter-name>sitemesh</filter-name>
        <filter-class>
            org.apache.struts2.sitemesh.FreeMarkerPageFilter
        </filter-class>
    </filter>
    <filter>
        <filter-name>struts2</filter-name>
        <filter-class>
            org.apache.struts2.dispatcher.FilterDispatcher
        </filter-class>
    </filter>

<filter-mapping>
    <filter-name>struts2-cleanup</filter-name>
    <url-pattern>/*</url-pattern>
</filter-mapping>
<filter-mapping>
    <filter-name>sitemesh</filter-name>
    <url-pattern>/*</url-pattern>
</filter-mapping>
<filter-mapping>
    <filter-name>struts2</filter-name>
    <url-pattern>/*</url-pattern>
</filter-mapping>

I haven't installed any extra libraries since from my understanding everything is included
in the struts package. I have all struts2 libraries loaded from the "all" package.

Hmm, any ideas? I have a feeling I'm missing some sort of configuration?

Regards,
Paul
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message