struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Ruggles <a.rugg...@gmail.com>
Subject Re: Validation Random Failures
Date Sat, 14 Apr 2007 06:29:58 GMT
I'm having a similar problem.  I'm extending the ActionSupport object 
and I have no validation specified and I'm experiencing the same issue.  
I did enable validation and the results didn't change.  The application 
was previously built on webwork2 where I didn't experience these issues 
at all.

I don't know if it has been logged as a bug. Because it happens randomly 
I haven't been able to find out where it's dying.

Zach Calvert wrote:
> I'm receiving random/spontaneous failures of validation on valid
> entries.  I can use the browser back button, re-submit the same data,
> and sometimes get it accepted.  I'm using simple Required strings:
>     @Validations(
>             requiredStrings = {
>                     @RequiredStringValidator(type = 
> ValidatorType.SIMPLE, fieldName =
> "company", message = "You must enter a value for company.",
> shortCircuit = true, trim = true)}
>     )
>
> I'm curious if there is a bug logged that I haven't found, a patch, or
> a new jar I need to download.  I'm using struts2-core-2.0.6.jar and
> freemarker-2.3.8.jar
>
>
> Anyone have any input?
>
>
>
> Thanks,
> Zach Calvert
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message