struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "MAthuvathanan Mou." <cowboyma...@gmail.com>
Subject href in the display tag does not work
Date Tue, 10 Apr 2007 11:24:08 GMT
Hi,

I use this jsp in my project


     <form name="form1" method="post"
action="/EmailToSMS/emailSmsAlertsAct.do?do=executeSmsAlerts">



                      <display:table border = "0" width="100%"
scope="session"  pagesize="15" offset="15" name="emailSmsAlertsAtt"
styleClass="table_report" requestURI="receivingSmsReportPaging.do">
                      <display:column property="mailaddress" title="Email
Address" width="17%" align="left" sort="list" />
                      <display:column property="pop3" title="POP server"
width="13%" align="left" sort="list" maxLength="15" />
                      <display:column property="smtp" title="SMTP server"
width="10%" align="left" sort="list" maxLength="15" />
                      <display:column property="password" title="Mobile
Number" width="10%" align="left" sort="list" />
                      <display:column property="type" title="Type"
align="left" width="10%" sort="list" />
                      <display:column property="frequency" title="Time
Interval" width="10%" align="left" sort="list"  maxLength="40"/>
                      <display:column property="edit" title="" width="10"
align="left" sort="list" href="emailSmsAlertsOpt.do?do=edit" />
                      <display:column property="remove" title="" width="10"
align="left" sort="list"
href="emailSmsAlertsOpt.do?do=remove"paramId="mail"
paramProperty="mailaddress" />
                      <display:column property="filter" title="" width="10"
align="left" sort="list"
href="emailSmsAlertsOpt.do?do=filter"paramId="mail"
paramProperty="mailaddress" />

                      <display:setProperty name="sort.behavior" value="list"
/>
                      <display:setProperty name="
paging.banner.include_first_last" value="true" />
                      <display:setProperty name="table_report" value="true"
/>
                      </display:table>


                <TD ><html:submit value="Add Email" property="addEmail"
/></TD>
</form>


I made proper struts mapping via struts-config.xml and Actio servlet. But
when I click the link in the table it just goes to blank page with related
URls but no server error messages.

Any wrong in my code?

Or using form action and href together, is it giving that prob?

Thanks,

Regards
MAthu M.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message