struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manickam-Periaswamy.Vign...@epamail.epa.gov
Subject Unknown tag error
Date Wed, 04 Apr 2007 21:38:06 GMT
Hi all

I am trying to run this sample application. 
http://struts.apache.org/2.x/docs/simplelogin-with-session.html

I am getting errors in this page welcome.jsp

<%@ page language="java" contentType="text/html; charset=ISO-8859-1"
    pageEncoding="ISO-8859-1"%>
<%@ taglib prefix="ww" uri="/webwork" %>
<jsp:include page="WEB-INF/inc/loginCheck.jsp" />
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Welcome</title>
</head>

<body>Welcome, you have logined. <br />
The attribute of 'context' in session is
<ww:property value="#session.context" />
<br /><br /><br />
<a xhref="<%= request.getContextPath() %>/logout.action">Logout</a>
<br />
<a xhref="<%= request.getContextPath() %>/logout2.action">Logout2</a>
</body>
</html>

It says "ww.property" Unknown tag. I know that webwork is outdated, so I 
changed 
"<%@ taglib prefix="ww" uri="/webwork" %>"

as 

<%@ taglib prefix="ww" uri="/struts" %>

But still it doesn't work. Any help?

Also it doesn't recognize "xhref". Please help

Thanks


Vignesh Manickam Periaswamy
Web Application Developer Intern, Information Management Section
WPTD,   EPA Region 5         312-886-0887
email: Manickam-Periaswamy.Vignesh@epa.gov


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message