struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manickam-Periaswamy.Vign...@epamail.epa.gov
Subject Re: Unknown tag error
Date Wed, 04 Apr 2007 21:59:11 GMT
Should I define a taglib for the uri "struts" and point it to location 
"struts-tags.tld"?

I read that struts 2 automatically locates struts-tags.tld from the 
struts-core.jar and we need not define taglib for that. What am I missing 
here?

Thanks

Vignesh Manickam Periaswamy
Web Application Developer Intern, Information Management Section
WPTD,   EPA Region 5         312-886-0887
email: Manickam-Periaswamy.Vignesh@epa.gov





Adam Ruggles <a.ruggles@gmail.com> 
04/04/2007 04:51 PM
Please respond to
Struts Users Mailing List <user@struts.apache.org>



To
Struts Users Mailing List <user@struts.apache.org>
cc





Subject
Re: Unknown tag error



Do you have the uri defined in your web.xml file?

Manickam-Periaswamy.Vignesh@epamail.epa.gov wrote:
> Hi all
>
> I am trying to run this sample application. 
> http://struts.apache.org/2.x/docs/simplelogin-with-session.html
>
> I am getting errors in this page welcome.jsp
>
> <%@ page language="java" contentType="text/html; charset=ISO-8859-1"
>     pageEncoding="ISO-8859-1"%>
> <%@ taglib prefix="ww" uri="/webwork" %>
> <jsp:include page="WEB-INF/inc/loginCheck.jsp" />
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
> <title>Welcome</title>
> </head>
>
> <body>Welcome, you have logined. <br />
> The attribute of 'context' in session is
> <ww:property value="#session.context" />
> <br /><br /><br />
> <a xhref="<%= request.getContextPath() %>/logout.action">Logout</a>
> <br />
> <a xhref="<%= request.getContextPath() %>/logout2.action">Logout2</a>
> </body>
> </html>
>
> It says "ww.property" Unknown tag. I know that webwork is outdated, so I 

> changed 
> "<%@ taglib prefix="ww" uri="/webwork" %>"
>
> as 
>
> <%@ taglib prefix="ww" uri="/struts" %>
>
> But still it doesn't work. Any help?
>
> Also it doesn't recognize "xhref". Please help
>
> Thanks
>
>
> Vignesh Manickam Periaswamy
> Web Application Developer Intern, Information Management Section
> WPTD,   EPA Region 5         312-886-0887
> email: Manickam-Periaswamy.Vignesh@epa.gov
>
>
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message