struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Musachy Barroso" <musa...@gmail.com>
Subject Re: AJAX div loads local URL but not remote one
Date Sun, 08 Apr 2007 02:58:18 GMT
Dojo supports crossdomain XHR using IFrames, but the ajax tags do not
support it, yet.

musachy

On 4/7/07, Eduardo Kortright <ekortright@gmail.com> wrote:
>
> Sorry about that... cut and paste went crazy on me; let me try
> again.  Here
> is the JSP again:
>
> <%@ page language="java" contentType="text/html;
> charset=ISO-8859-1" pageEncoding="ISO-8859-1"%>
> <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "
> http://www.w3.org/TR/html4/loose.dtd">
> <%@ taglib prefix="s" uri="/struts-tags" %>
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
> <title>Welcome</title>
> <s:head theme="ajax"/>
> </head>
> <body>
> <hr/>
> <s:div theme="ajax" id="search" href="
> http://localhost:8080/Struts2-tutorial1/">
>   Local page goes here.
> </s:div>
> <hr/>
> <s:div theme="ajax" id="live365" href="http://www.google.com"
>   loadingText="Please wait . . ." errorText="Sorry, can't load remote
> page">
>   Remote page goes here.
> </s:div>
> <hr/>
> </body>
> </html>
>
>
> On 4/7/07, Eduardo Kortright <ekortright@gmail.com> wrote:
> >
> > Hi all,
> >
> > I'm trying to learn how to use AJAX, but I'm having some trouble.  In
> the
> > JSP below, the first <s:div/> loads the URL just fine, but the second
> > <s:div/> simply displays "Loading..." and stays that way forever.  IE
> > displays "Error on page" in the status bar when it is (apparently)
> trying to
> > contact the server, then "Done".  Is there anything that needs to be
> done
> > differently for a remote URL?
> >
> > Thanks.
> >
> > --
> > Eduardo
> >
>



-- 
"Hey you! Would you help me to carry the stone?" Pink Floyd

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message