struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laurie Harper <lau...@holoweb.net>
Subject Re: Struts in Servlet 2.4
Date Sat, 14 Apr 2007 17:14:14 GMT
Slattery, Tim - BLS wrote:
>> I found this to be a great tutorial
>> http://www.exadel.com/tutorial/struts/5.2/guess/strutstutorial.html
>>
>> Create your formbean with public Accessors/Mutators for each 
>> private attribute and also create methods for reset method 
>> validateMethod and of course public no arg constructor for bean
>>
>> in struts-config.xml configuration define the Bean <form-beans>
>>   <form-bean name="NameOfBeanForm" 
>> type="package.NameOfBeanForm"/> </form-beans>
>>
>> so later in your jsp you will be able to access the 
>> FormAttribute <html:html>  <html:form 
>> action="PathForAction".. >  <html:text property="AttributeFromForm"
> 
> Thanks, but I don't think that has anything to do with what's happening
> here. This app works under WL8, and I'm having trouble getting it to
> work in WL9. The problem right now is this <html:link...> tag, which
> asks for a property named solicitationNumber in a bean named Contact.
> It's not the form's default bean, the Action doesn't have any problem
> getting its form bean. I've verified that it saves the proper bean in a
> session attribute named "Contact". The tag says it can't find it. Dead
> end.

Tim, have you tried examining the content of the session at JSP render 
time, either using the s:debug tag or some other custom tag or 
scriptlet, to confirm that the bean really got stored to the session 
under the name you think it did?

L.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message