struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeromy Evans <jeromy.ev...@blueskyminds.com.au>
Subject Re: dojo form submission not working in IE
Date Mon, 03 Sep 2007 07:56:22 GMT
In IE6 the s:a can't have a target equal to a div that contains the 
itself unless you set showLoadingText=false

The problem is that in IE6 the form nodes are overwritten by the loading 
text before its actually read and posted.  Disable the loading text and 
it will be okay.

regards,
 Jeromy Evans

Hari Prasad wrote:
> Hi,
>    I used simple ajax form submission in my application and it worked in
> both Mozilla and Internet Explorer.
>    and now, I shifted to DOJO and my form is like this..
>
>          <@s.div id="login_box_ajx" theme="ajax">
>
>          <@s.form action="login" name="login_form" id="login_form"
> method="POST" theme="ajax">
>                         <@s.hidden name="test" value="checkthis"/>
>                         <@s.a theme="ajax" formId="login_form" name="Go"
> targets="login_box_ajx" tooltip="Go">
>                                     /go_button.gif  
>                         </@s.a>
>          </@s.form>
>
>          </@s.div>
>
>
> all I want to do is to submit the form and return some data and put it into
> the div.
> Its working in Mozilla , but not if IE , the request parameters are not
> comming in IE.
>
> can anyone suggest me what to do?
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message