struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Beech" <a.be...@bigpond.net.au>
Subject [S2] Referencing the taglib when the JARS's are located at the top level of an EAR package?
Date Fri, 28 Dec 2007 07:41:16 GMT
G'day all,

I've been tinkering with Struts for the first time over the past few days
and have come across a small issue with the way I'm building/packaging the
EAR file and how the JSP's reference the Struts taglib.  The various JAR's
are bundled at the top level of the EAR package in a "lib" directory.  Using
the "<%@ taglib prefix="s" uri="/struts-tags" %>" in the JSP's is giving me
no end of grief as I'm assuming, going by the error messages, /struts-tags
cannot be resolved.  Moving the relevant JARS to the WEB-INF/lib directory
appears to work just dandy.  Can someone please enlighten me on what I need
to do to fix this situation, i.e. do I need to use a different URI, add
something to the manifest, add something to either the
META-INF/application.xml or META-INF/orion-application.xml files, etc?

I'm using the bundled instance of OC4J which comes with JDeveloper 10G.  At
this stage though the test applications are not being maintained within
JDeveloper... all aspects of the application are coded from scratch and
built using a custom ANT build script.

No doubts this question highlights my obvious lack of knowledge regarding
Struts and especially relating to the creation of EAR's, etc.  I've more
than likely missed something in both the Oracle and Struts documentation
which covers this sort of issue?

Thanks for your assistance with this one.  It'll be greatly appreciated!

Cheers.
AB


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message