struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thecyth <thec...@hotmail.com>
Subject [Struts 2] Unable to access resources
Date Sat, 01 Dec 2007 21:11:13 GMT

I get this error message when I try to access ANY of the 
resources in my app. 

The requested resource (/EcoSim/web/welcome.action) is not 
available. 

Here's my setup: 

------------------ 
welcome.jsp: 
<%@ page contentType="text/html; charset=UTF-8" %> 
<%@ taglib prefix="s" uri="/struts-tags" %> 
<html> 
<head> 
<title>Please log-in...</title> 
</head> 
<body> 
<s:form action="WelcomeAction" method="POST"> 
... 
</s:form> 
</body> 
</html> 
------------------ 
web.xml: 
<?xml version="1.0"?> 
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD 
Web Application 2.3//EN" 
"http://java.sun.com/dtd/web-app_2_3.dtd"> 

<web-app id="WebApp_9" version="2.4" 
xmlns="http://java.sun.com/xml/ns/j2ee" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee 
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"> 
<display-name>EcoSim</display-name> 
<filter> 
<filter-name>struts2</filter-name> 
<filter- 
class>org.apache.struts2.dispatcher.FilterDispatcher</filter-class> 
</filter> 

<filter-mapping> 
<filter-name>struts2</filter-name> 
<url-pattern>/*</url-pattern> 
</filter-mapping> 

<welcome-file-list> 
<welcome-file>index.html</welcome-file> 
</welcome-file-list> 
</web-app> 
------------------------ 
struts.xml: 
<!DOCTYPE struts PUBLIC 
"-//Apache Software Foundation//DTD Struts Configuration 
2.0//EN" 
"http://struts.apache.org/dtds/struts-2.0.dtd"> 

<struts><!-- Configuration for the default package. --> 
<package name="actions" namespace="/" 
extends="struts-default"> 
<action name="WelcomeAction" 
class="actions.WelcomeAction"> 
<result>/web/success.jsp</result> 
</action> 
</package> 
</struts> 
-------------- 

I can get the struts blank project loaded just fine. When I deploy 
my war file, the system gets angry at 
me... I've been stuck on this problem for days now, any help 
would be greatly appreciated!
-- 
View this message in context: http://www.nabble.com/-Struts-2--Unable-to-access-resources-tf4929583.html#a14109568
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message