struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wes Wannemacher" <w...@wantii.com>
Subject Re: S2 - using display tag with Struts
Date Tue, 11 Dec 2007 20:20:01 GMT
Is there an error in your App Server log? Sometimes, if there is an
exception while sending output, it can bomb out part of the way
through. Check your logs to see if you find an exception that might
help narrow the problem down a little.

-Wes

On 12/11/07, Serge Bornow <serge.bornow@architech-solutions.com> wrote:
> Hello Everyone,
>
> First of all let me wish you merry Christmas and happy new year.
>
> I have a small question to those that use display tag.
>
> I have a page:
>
> <%@ taglib uri="http://displaytag.sf.net" prefix="display" %>
> <%@ taglib uri="/struts-tags" prefix="s" %>
>
>
> <html>
>     <head>
>         <title>Test</title>
>
>         <s:head theme="simple" />
>         <s:debug/>
>     </head>
>     <body>
>         <s:set name="persons" value="persons" scope="request"/>
>
>
>         <display:table name="persons"  id="row" >
>
>
>             <display:column property="name" title="Name"/>
>             <display:column property="gender" />
>
>         </display:table>
>     </body>
>
> </html>
>
> I also have a simple POJO called Person with  name and gender as its fields.
>
>
> And a  mapped action e.g. myaction so i browse myaction.action
> which contains a field private List<Person> persons;
> with get and set methods.
> In the execute()
> i add a few dummy objects to the list
> this.persons = new ArrayList();
>
>         Person per = new Person();
>         per.setName("serge");
>         per.setGender("m");
>
>         this.persons.add(per);
>
>         per.setName("serge Bornow");
>         per.setGender("MM");
>         this.persons.add(per);
>
> Btw i have the display jar in my classpath
>
> Now when i load that page, nothing shows up.
>
>
> In fact something screws this process , this is the output: (view source)
>
> <html>
>     <head>
>         <title>Test</title>
>
>         <script type="text/javascript">
>     // Dojo configuration
>     djConfig = {
>         baseRelativePath: "/TestStruts2/struts/dojo",
>         isDebug: false,
>         bindEncoding: "UTF-8",
>         debugAtAllCosts: true // not needed, but allows the Venkman debugger to work
with the includes
>     };
> </script>
> <script type="text/javascript"
>         src="/TestStruts2/struts/dojo/dojo.js"></script>
> <script type="text/javascript"
>         src="/TestStruts2/struts/simple/dojoRequire.js"></script>
>
>
>
>
> And not even a closing tag </body>  etc
>
>
>
> I would really appreciate an advice.
>
> Thank you kindly,
>
> Serge
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>


-- 
Wesley Wannemacher
President, Head Engineer/Consultant
WanTii, Inc.
http://www.wantii.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message