struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paranoid_Fabio <paranoid_fa...@yahoo.it>
Subject Re: Parameters in URL
Date Fri, 15 Feb 2008 08:46:35 GMT

I'm sorry but I meant "includeParams=none". I wrote it correctly in the code
but I posted it wrong.
The result is the same, params are included in the url.
The code is:

         <s:url id="en" action="showAdminPage" includeParams="none">
         	<s:param name="request_locale">en_US</s:param>
         </s:url>
         <s:a href="%{en}">




Paranoid_Fabio wrote:
> 
> Hi, i'm new to struts. I'm developing a web application and I can't
> understand why parameters still in the url beetwen actions calls. I try to
> explain it better (sorry for my poor english):
> 
> I call "myAction?paramx=valuex" and the url becomes
> ".../myAction?paramx=valuex" correctly.
> 
> Then, my new displayed JSP call "myAction2" but the shown url is
> ".../myAction?paramx=valuex" even if i invoked myAction2 without any
> parameter.
> So I've two questions:
> 
> 1)It's only a display thing or paramx=valuex is actually passed also to
> myAction2?
> 2)How I can avoid this behaviour?I read about includeparams=false in
> struts.xml, but I'm not sure if it's the   right solution... 
> 
> Thank you in advance!!
> 
> 

-- 
View this message in context: http://www.nabble.com/Parameters-in-URL-tp15485039p15496167.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message