struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From carmi_cd <carmi_...@yahoo.com>
Subject Re: [S2] Validation
Date Tue, 19 Feb 2008 06:52:19 GMT

i was able to identify the problem it was only in IE,I put the
showLoadingText="false"
to my save button then it validates correctly before it wasn't able to get
the form values in IE.

still thanks newton.date.  :-)



newton.dave wrote:
> 
> --- carmi_cd <carmi_dom@yahoo.com> wrote:
>> Hi I have an application in Struts 2, my problem is when 
>> i try to submit the form even if there are values in the 
>> form input box it stills give validation message to the 
>> user to enter values for the required fields. 
>>
>> here is my form fields.
>> <s:textfield name="employeeId" label="Employee ID" labelposition="left"
>> value="%{edituser.empId}" size="10"/>
>> <s:textfield name="lastname" label="Lastname" labelposition="left"
>> value="%{edituser.lastName}" size="30"/>
> 
> You're validating on "lastName" etc; do you have getters and setters for
> "lastName" and so on, or are you assuming there's a getEdituser() and all
> the
> values are being set on the edituser bean?
> 
> Dave
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/-S2--Validation-tp15539111p15557767.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message