struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chriss Nold" <chriss.n...@gmail.com>
Subject Problems setting up example applications
Date Mon, 18 Feb 2008 10:10:43 GMT
 I am new to both Eclipse and Struts2 and I am having issues with the
struts2 examples.
First, I open eclipse and import the .war file for the blank project, and
set the Eclipse configuration to add it is a Tomcat project. When I attempt
to access the app, it fails to find the action mappings. It appears to crash
at the following line of the index.html:
   <META HTTP-EQUIV="Refresh" CONTENT="0;URL=example/HelloWorld.action">
giving the error in the browser:
The requested resource (There is no Action mapped for action name
HelloWorld.) is not available.
and in the console:
There is no Action mapped for action name HelloWorld. - [unknown location]
and, before it fails, the app forwards to the URL:
http://localhost:8080/Blank/example/HelloWorld.action

The action mapping is present in the example.xml which is included in the
struts.xml.
This is occurring with no modifications to the project.

Upon importing the showcase .war file included in the struts2 download, I
immediately receive seven errors of "invalid </p> tags" in the .jsp's. All
of these are following <ol>, <ul> or <li> tags.
In an attempt to at least get it to start, I removed these end tags and
configured it as a Tomcat project. When I restart the server, showcase fails
(during the server restart) giving the following error:
SEVERE: Error configuring application listener of class
org.apache.struts2.showcase.chat.ChatSessionListener
java.lang.ClassNotFoundException:
org.apache.struts2.showcase.chat.ChatSessionListener
at org.apache.catalina.loader.WebappClassLoader.loadClass(
WebappClassLoader.java:1358)
at org.apache.catalina.loader.WebappClassLoader.loadClass(
WebappClassLoader.java:1204)
at org.apache.catalina.core.StandardContext.listenerStart(
StandardContext.java:3773)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4337)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:516)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:566)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java
:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(
DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)

The .java file is in the location listed, and the build file also appears to
be in the proper location.
I am running Eclipse Europa and tomcat 6 on an XP box with jre 6 and
jdk 1.6with MySQL.

 Any help that you can offer would be greatly appreciated.

Thank you,
Chriss

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message