struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mteccles <mark.t.ecc...@googlemail.com>
Subject Re: Troubles getting validation to work
Date Mon, 03 Mar 2008 15:15:22 GMT

workflow interceptor was missing, this was the problem. 


newton.dave wrote:
> 
> --- mteccles <mark.t.eccles@googlemail.com> wrote:
>> I am trying to validate a form so that field 'username' is 3 characters
>> or
>> more. I have tried both xml configuration and annotations but seem to be
>> missing something on how it works. The form is working perfectly, ie all
>> properties on the class are being set. However the execute method is
>> always
>> called and returns SUCCESS. Should the validation interceptor stop
>> invokation of the action and return Action.INPUT? Based on the S2
>> tutorials
>> i did everything required. Could the use of tiles be breaking it? Pls see
>> the source below.
> 
> I don't see where you're defining your interceptor stacks. (And your
> action
> defs have interceptor-refs in two different places; I'd put them all in
> one
> place for clarity.)
> 
> Do your interceptor stacks include the "workflow" interceptor?
> 
> Dave
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Troubles-getting-validation-to-work-tp15799918p15806043.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message