struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sassien <sass...@hotmail.fr>
Subject [S2] Menu Tag Library struts-config.xml problem.
Date Wed, 02 Apr 2008 16:12:00 GMT

Hello all,

I am used to JSF, and, trying to learn how to handle struts 2, I noticed
that there is no integrated tag to create menus (like richFaces, for
example).
So I found this library: "Struts-menu", which had initially been written for
Struts 1.
http://struts-menu.sourceforge.net/userguide.html
http://struts-menu.sourceforge.net/userguide.html 
I guess you guys know it and I wonder how you made it work. I found a few
threads on this subjects but they were not really helpful for me:

according to the documentation, we have to configure the struts-config.xml
file. Ok, but I don't have any struts-config.xml file... I thought it was
not useful in struts 2.
Anyway, created one and I wrote this to reference the plugin:

<struts-config>
<plug-in className="net.sf.navigator.menu.MenuPlugIn">
  <set-property property="menuConfig" value="/WEB-INF/menu-config.xml"/>
<!-- Default settings -->
</plug-in>
</struts-config>

Then I created the menu-config.xml file, with this code:

</MenuConfig>

<Displayers>
 <Displayer name="TabbedMenu"
type="net.sf.navigator.displayer.TabbedMenuDisplayer"/>
</Displayers>

<Menus>
 <Menu name="contactMenu" title="Contact" location="?Contact">
   <Item name="email" title="E-Mail" location="?EMail"/>
   <Item name="phone" title="Phone" location="?Phone"/>
 </Menu>
</Menus>

</MenuConfig>

in summary, I did exactly what was written on the "userGuide" page. But I
still get this error that says that the menu repository could not be
obtained...
Looking on forums, I found that it could be because of a library, so I tried
to add every library included in the sample application which we can
download on the same website. Nothing helps...

By the way, this sample application does work, if I deploy it, but I cannot
find the way to make the menus work on my own project. Anyway, it seems that
this sample application is made with struts 1, so it does not really help in
my case.

I guess that I am not the only one that have or will have this problem, so
maybe someone who did it can give a summary of how to configure this library
on struts 2?

Actually, I wonder if the application considers the "struts-config.xml"
file, as it has not been referenced anywhere... I tried to add something in
the "web.xml" file to reference it, but then everything crashed, so now I
might give up... actually I would already have done it if I had found an
other menu-library ;-)

I hope someone will be able to answer my question, and I hope my text is
clear enough... :-)
regards,
sassien
-- 
View this message in context: http://www.nabble.com/-S2--Menu-Tag-Library-struts-config.xml-problem.-tp16447334p16447334.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message