struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Piero Sartini <li...@pierosartini.de>
Subject Re: Problem url decoding with mutated vowels (Umlaute??)
Date Mon, 14 Jul 2008 14:35:39 GMT
Hello,

you can try the following settings in struts.xml:
    <constant name="struts.i18n.encoding" value="UTF-8"/>
    <constant name="struts.locale" value="de_DE"/>

Please let me know if this resolves your issue.

	Piero

Am Montag, 14. Juli 2008 15:25:14 schrieb Marc Eckart:
> Hi,
>
> we have an action which we call with url paramters from other applications.
>
> But now we found out, that we have problems with mutated wowels like äöü.
>
> Instead of  tls-hölter we get tls-hölter in the parameterMap of  the
> servletRequest (I debugged).
> I assume that the parameters are decoded with iso ISO-8859-1 instead
> of utf-8 or otherwise.
>
> Is there an option to tell struts2 which charset it should use to decode?
>
> The url looks like this:
> http://localhost:8080/bpc/search.action?ctxSid=20080714082158393251000&user
>Id=xxx&pageTitle=Bla&returnUrl=http://localhost:9080?methodToCall=loadWithCu
>stDetails&simpleSearch=tls-h%C3%B6lter
>
> We call the application running on tomcat from an application running
> on websphere 6.1.
>
> Thanks in advance...
>
> Best regards,
> Marc
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message