struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milan Milanovic <milanmilanov...@yahoo.com>
Subject Re: [S2] Iterate through two lists
Date Thu, 21 Aug 2008 16:00:56 GMT

Hi Dave,

it is an object that contains list of Fruits, nothing else. Yes, it is
located in action class and have get/set methods.

--
Milan


newton.dave wrote:
> 
> What is "someObject"? Have you created it as a named stack context
> variable?
> 
> Dave
> 
> --- On Thu, 8/21/08, Milan Milanovic <milanmilanovich@yahoo.com> wrote:
> 
>> From: Milan Milanovic <milanmilanovich@yahoo.com>
>> Subject: Re: [S2] Iterate through two lists
>> To: user@struts.apache.org
>> Date: Thursday, August 21, 2008, 11:41 AM
>> Dear Dave,
>> 
>> 
>> newton.dave wrote:
>> > I'd say something is wrong either in the action
>> configuration or code;
>> > even if the OGNL didn't work (AFAIK it should) I
>> don't think it would
>> > cause a 500.
>> > 
>> 
>> When I remove this "push" code I don't get
>> this error.
>> 
>> 
>> newton.dave wrote:
>> > Do you have devMode turned on and logging turned up?
>> Have you verified
>> > that you have access to the two lists without all the
>> looping and pushing
>> > and whatnot?
>> 
>> Yes, I have devMode turned on in struts.xml and loggin is
>> turned up, I
>> always get some messages in console. Yes, both of my two
>> lists have accesss,
>> get/set methods.
>> 
>> --
>> Regards, Milan
>> 
>> 
>> 
>> newton.dave wrote:
>> > 
>> > --- On Thu, 8/21/08, Milan Milanovic wrote:
>> >> I tried to adopt your solution, like this:
>> >> 
>> >> <s:iterator value="#list1"
>> status="rowstatus">
>> >>   <s:text name="names" >
>> >>     <s:push
>> value="#someObject.list2[#rowstatus.index]">
>> >>       <s:param name="value"
>> value="name"/>
>> >>     </s:push>
>> >>   </s:text>
>> >> </s:iterator>
>> >> 
>> >> but I get: Error loading
>> 'myApp/showFruits.action'
>> >> (500 Internal Server Error),
>> >> and there is nothing in log.
>> > 
>> > I'd say something is wrong either in the action
>> configuration or code;
>> > even if the OGNL didn't work (AFAIK it should) I
>> don't think it would
>> > cause a 500.
>> > 
>> > Do you have devMode turned on and logging turned up?
>> Have you verified
>> > that you have access to the two lists without all the
>> looping and pushing
>> > and whatnot?
>> > 
>> > Dave
>> > 
>> > 
>> >
>> ---------------------------------------------------------------------
>> > To unsubscribe, e-mail:
>> user-unsubscribe@struts.apache.org
>> > For additional commands, e-mail:
>> user-help@struts.apache.org
>> > 
>> > 
>> > 
>> 
>> -- 
>> View this message in context:
>> http://www.nabble.com/-S2--Iterate-through-two-lists-tp19052842p19091427.html
>> Sent from the Struts - User mailing list archive at
>> Nabble.com.
>> 
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail:
>> user-help@struts.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/-S2--Iterate-through-two-lists-tp19052842p19091806.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message